Walked through How-to install Tactical and MeshCentral install and

So it looks like the install went through -


I am right at the part where I am supposed to login for the first time at rmm.company.com
but it is not pulling up the login like in the instructions shows, it’s pulling up my website instead. So either my adjustments to the 3 domains haven’t resolvable or something else isn’t correct.

here is the original post on How-To -

I guess I will wait, but does anyone have any test I can try to track down if it is setup properly?

Any thoughts?

Yeah, definitely was not replication. Still not coming up at rmm.company.com. Has to be another issue.
Looking at reverse proxy. Shouldn’t be that, but not sure what else could be causing issue.

Gonna step back through the How-To and see what I come up with…

Can you show where in the how to you got stuck pls? I guess reverse proxy?

1 Like

Well, a little progress. I am now getting passed it showing my business website, I am now getting the following.


Here is the reverse proxy on the server.

I am still not getting to the login from rmm.company.com <— this is obviously not the real address.

I did re-rerun the following commands…

signal-event nethserver-docker-update


docker-compose up -d

to make sure the docker firewall and container are working…

I got the following…



I am using other tools externally, such as



to help externally make sure things are working as well…

Hi @Shadowfire

AFAIK, you should NOT use the GUI to create the virtual host, only the command line.
Try removing the virtual host, and set the virtual host the same as for the module (MeshCentral).

See here:


I’ve set up about 30 NethServers for my clients, and almost all are equipped with MeshCentral (Module). So far, the installlation works well just using the module. I don’t use TacticalRMM, even though all NethServers are running AD.

My 2 cents

1 Like

@mrmarkuz @Andy_Wismer @LayLow I wanted the TRMM and MeshCentral, but I was hitting roadblocks with docker, reverse proxy, and possibly the cert. I am getting tight on time, so I guess for right now I would like to get MeshCentral working like Andy was suggesting. (I can always get the TRMM working later.) I hope MeshCentral has a migration export for data. Guess I will find out later.

the MeshCentral NethServer Wiki says…

Valid Certificate and Virtualhost needed

MeshCentral needs a valid certificate to work. You may use a Letsencrypt certificate. To be reachable for users and agents, MeshCentral needs a dedicated virtualhost, an FQDN like mydomain.org. You may use a Dynamic DNS provider.

Is there anyway to make MeshCenral work like webtop and nextcloud and have it work like example www.website.com/webtop, www.website.com/nextcloud.

so like www.website.com/mesh ???


AFAIK, it needs the LE certificate, which is - as such - quite easy to implement on NethServer.
But you do need a valid DNS hostname!

I use for home and my clients a name like mesh.domainname.tld.

→ You can think of E-mail. Sure you can setup a mailserver without a valid LE. Just import the self generated cert into your client and it’s good!

Think again!

Most Smartphones, but also “normal” desktop clients like Outlook or Mac Mail can be setup to work like this. The BIG but is that it often does not work longer than a week with desktop clients. With Smartphones (No matter if Android or iOS) it often works exactly once! So yeah, sure you can use it without a valid LE cert, but you need to fix the server and often ALL clients on a daily or weekly basis!

→ Not really usable as such!

With a valid LE cert, you’ll probably find that Mesh & TRMM will install in 15-20 minutes and works without issues!

A Dynamic IP works, eg with DynDNS, without any issues.
A name like mesh.mydomain.dyndns.org works also, even using the wildcard
( *.mydomain.dyndns.org ).
You can also use a dynamic IP name to point your “real” domain to, using a CNAME. I can confirm that this is rock solid!

My 2 cents


I can confirm that the instructions from Howto install Tactical RMM including MeshCentral on Nethserver with docker don’t work anymore.
It seems TacticalRMM updated their docker installation, I need to check and repair the howto…

No, MeshCentral requires a separate domain name.


I found the port redirection in the howto was wrong so I corrected it:


I appreciate everyone trying to help. The energy and wiliness to help a fellow professional, user, and hobbyist out. I figure I will give you a little more to my current challenges for the part of last week till now, it has been an informative and adventurous with me finally having and taking the time to do some much needed review and maintenance at my office.

Normally I am helping others get their computer needs, as well as onprem, vm and hosted servers setup and up keep done. Saddly I have been just be squeezing through with my own tech and servers.
Some would call it slighly neglecting… :face_with_peeking_eye: :face_with_hand_over_mouth: :open_mouth:

Like I said I have finally taken the proper amount of time in between remotes and onsite visits to customers the end of last week and this whole week I have been putting in time to catch-up with maintenance on my servers, workstations, and other devices at my office.

This included some adjustments locally to my server hardware wise, including added features to Backups / Webtop / NextCloud / other misc stuff.

I am having to make another decision that not only effects me but also my clients. So it was time to review what I was going to do with my move from Connectwise (they are no longer supporting Linux server package for remote support).

No offense to anyone, I work on Microsoft Servers a lot through most of my support sessions and onsite visits through my days, but I am not interested in using a Microsoft Server at my office. That has been the beauty of Nethserver for me. I set it and almost can forget it. It has taken care of most if not all my needs so far. As well as for my customers who have dared to go Linux to fix and help their business needs. It’s sad they are fed some much FUD and can not trust Linux, even though it’s been tried and is true and just works if handled correctly.

So back to Connectwise, I was using it before it became Connectwise… It was originally called Screenconnect. You have to understand I was on the look out for other possiblities like Connectwise, NinjaOne, and so on for a bit now… with Connectwise getting bought out and seeing the support level tank from other friends in the business (my personal opinion), I was not interested in living in that mess.

So when I read about Mech Central in the Neth Forums and then caught wind of TRMM… At that point I wanted to change over to Mech and if possible TRMM. This would be a major win for me and my clients as well. Sitting on top of a NethServer would be amazing.

So it was my hope to get this all worked out before I have to hit the pavement again come next week.

Yes, I believe LE certs are majorly easy through Nethserver. I do have a valid DNS hostname.

I am currently using LE on my Nethserver, for my website, Webtop, Nextcloud, and I was hoping to use it for TRMM and Mesh.

In an earlier post you mentioned

Are you meaning that I should uninstall webserver module? or just the root virtual host? You can not just remove the root virtual host … at least it will not allow me to do it on my Nethserver. I am guessing you mean uninstalling webserver module.

Do you have a specific sample you can show me if I was to


Hi. No need to uninstall the webserver, just remove the specific virtual host for meshcentral if you created it through the GUI, as its assignment can conflict / cause problems with the module.

Often, like in this case, modules have their own semi-automated way of creating a virtual host without recurring to the generic GUI. So you can create the virtual host for the module from the command line (check again the example given on the wiki article for meshcentral);

config setprop meshcentral VirtualHost mydomain.org
signal-event nethserver-meshcentral-update

Usually virtual hosts created by the modules are not visible on the Virtual Host GUI page. That’s a small complaint some users here have (they would prefer every virtual host to be shown on the virtual host page even those from modules, even if those ones were read only).


Just this…

1 Like

So when I installed webserver, it created a root virtual host. It will not let me delete that one. So I am guessing you are not meaning that one. I did not add a virtual host though the GUI for meshcentral and got rid of the reverse proxy ones that I created for the TRMM.

I stepped through - meshcentral [NethServer Wiki]

Which means I did the -


Set the domain to reach the MeshCentral instance.

config setprop meshcentral VirtualHost mydomain.org

But still was unable to get to mesh.mydomain.org

config setprop meshcentral VirtualHost mesh.mydomain.org
signal-event nethserver-meshcentral-update

and then trying

config setprop meshcentral VirtualHost mydomain.org
signal-event nethserver-meshcentral-update

It doesn’t bring up mesh at mydomain.org

actually now it has interrupted my website, Webtop and Nextcloud. They no longer come up like before after invoking…

1 Like

That’s probably because of using the main domain name instead of a dedicated one.

That should be OK, assuming you included mesh.mydomain.org to the certificate.
When browsing to the meshcentral domain what is the error or what is shown?


When creating wild card or multiple doamin LE’s can I use the GUI for LE? for instance mydomain.org mail.mydomain.org mesh.mydomain.org api.mydomain.org rmm.mydomain.org?

or do I have to do it in CLI?

you can use the GUI

I did have the LE with mydomain.org mesh.mydomain.org api.mydomain.org rmm.mydomain.org… except mail.mydomain.org

Ok! Good news. It looks like it is working. I can see it now when going to mesh.mydomain.org… YAY!!!