V7.3.1611 Installation doesn't work

NethServer Version: 7.3.1611
Module: Installation

I downloaded V7.3.1611 and created a boot USB disk with fedora Live USB Creator and with Unvesal USB Installer as well. Every time it is booting from the USB and is doing something but finally it stucks.
I got the message which looks like is important:
Can’t get kickstart from /dev/sdc/ ks.cfg

I downloaded it twice and kreated the USB several time with different tools and downloads. Always the same.

Any idea what is going wrong?

Software like Live USB Creator and Universal USB Installer usually do some logic on the USB stick partitions and install a boot loader. In this case, anaconda can’t find the kickstart file for automatic configuration.

Try with this procedure:

http://docs.nethserver.org/en/v7/installation.html#usb-stick

I used the recommended Fedora Live USB Creator.

I don’t have a Linux system at hand to use DD.

I will try Rufus if this tool helps.

You can try with this software:

http://www.alexpage.de/usb-image-tool/

I use it to recovery the CFcards and SSD of the nethbox, and it works well.

The same as before. At the end I got the same information that ks.cfg isn’t there.

I tried interactive installation and unattended installation.

It looks like there is something missing to continue the installation. It doesn’t come to the point to do anything with the computer. As fare as I understand it test the hardware and need then ks.cfg and can’t find it. No CentOS installation is done and Nethserver either.

We tested the dd procedure multiple and works flawlessly.

In you case, you can workaround the problem by installing the CentOS then convert the installation to a NethServer.

Did you try with a different USB key or different server?
Could you share some details about your hardware? Is it centos 7.3 compatible?

1 Like

The reported problem is not hardware related, it’s just anaconda not finding the kickstart.

The script is going to the point where I got following message:
dracut-initqueue [580]: gzip: stout: Broken pipe
dracut-initqueue [580]: Warning: dracut-initqueue timeout - starting timeout sripts
dracut-initqueue [580]: Warning: dracut-initqueue timeout - starting timeout sripts

Then I get the anaconda with the information
Can’t find ks.cfg

I doesn’t comes to the point to install anything.

I burned a DVD and it working well at the moment. It looks like it will go through.

I am installing it on my server which I used for NS6. It should be compatible.

1 Like

The installation was successful from DVD.

@giacomo
The installation from a USB stick has definitive a problem. The different what I see is the dracut-initqueue number. From USB it is [580] and from DVD it is [578].
It would be nice if this problem could be solved.

I had similar issue with a Pendrive on a “single disk” install. I will try with a recorded DVD-R to confirm the issue.

Issue confirmed for my setup. After burning iso in the DVD, setup worked like a charm…

Tested some programs with nethserver-7.3.1611-x86_64.iso.
Windows programs were tested running under Windows 10.
NethServer installation tested on non-UEFI system.

  • Works = no problems found
  • Works but… = Program reported some errors; NethServer installation succeeded.
  • Does not work = self-explanatory

Works

Works but…

  • Fedora Media Writer (works but “USB media write verification” fails)
  • Rufus (in DD image mode) (works but some errors reported on Rufus’ log)

Does not work

7 Likes

You should collect that info into our wiki in order to not miss them!

I was quite close to install 7.6 using YUMI, but during partitioning anaconda deleted the partition table on my flash drive (64gb).