Replacing Win Server 2016 with Nethserver?

Alright, well ty everyone!

All my data is backed up. When I get home today I am wiping the server, installing and configuring Nethserver and wiping a Win 10 laptop to connect to Nethserver.

I think I am going to start by trying ZFS for my 4x 4TB drives with the OS on the 120GB SSD.

Presuming it all goes according to plan, I will wipe and connect the other Win 10 laptop tomorrow.

I am then going to consider if I AD join my Manjaro laptop or not. I presume it should be feasible, as I have been doing, to simply connect it to the desired shares without connecting it to the AD/Domain? Basically I have it (Manjaro laptop) setup how I like and are not too keen on wiping it and then re-tweaking it if I can avoid it.

I will likely try both BackupPC and UrBackup and either use both or decide which works bets in my setup.

I am likely to use ClamAV on the server as per @m.traeumner recommendations as well as on my Manjaro laptop. For the Windows 10 machines I am considering purchasing a consumer solution from either Bitdefender or McAfee in place of my business server/endpoint current setup using Bitdefender.

I am then excited to poke around in Nethserver and find new modules, programs, etc to get the most out of it.

I would of course be happy to report back with the progress, would it be best to start a new thread for that or to simply continue it in this thread?

Again, thank you all. Its rare these days to find software with decent documentation. Even more rare is finding software with a friendly, helpful and knowledgeable community. Nethserver has nailed both.

1 Like

If you’ll be using something more than ibay shares, I think it would be better to do custom partitioning for /var/lib/nethserver (where nethserver saves most of the data) instead of /var/lib/nethserver/ibay

Excuse my ignorance on the matter but…

What do you mean by?:

I am not sure exactly what an “ibay” share is and/or what alternatives there are to it.

As for custom partitioning could you maybe elaborate on the details of how I should approach it?

To clarify (and please correct me if it does not fit in with the Nethserver paradigm) I am very much a proponent of separating the OS and Data.

The way I see it is Nethserver would be installed on and anything related to the OS functioning, updating, programs, etc would be on my 120GB SSD. The 4x 4TB pool would be used as space for data, some (likely most or all of which) would be made available to others via shares across the network.

So if there is a way to elegantly change the default location of the shares to my pool (either during or after install) then I am all for it. However, another member advised me to mount to the default location instead of trying to alter the location of shares as I didnt find any option in the web GUI to specify the location/path of a share.

Thanks

for ibay share I’m referring to shared folders.

For instance, if you install nextcloud its data will be stored under /var/lib/nethserver/nextcloud/ , that’s why I suggested to use the other mountpoint (to store the data on the bigger disks)

At installation time you can change the storage/partition scheme to assign the mountpoint to the bigger disks array/pool. Cannot talk about ZFS.

The location (path) won’t change, you just assign a different underlaying storage to your convenience.

1 Like

So made install USB stick using Rufus from Windows machine.

Booted from usb and got:
‘dracut-initqueue[630]: warning: dracut-initqueue timeout - starting timeout scripts’

Repeated many times then left at dracut emergency shell.

I suspect my best course of action is to remake but media and try again? Google didn’t uncover anything that stood out as a common solution.

Make the bootable usb drive with Etcher instead.
Some notes on Rufus: V7.3.1611 Installation doesn't work

Thanks.

Rufus gave UEFI boot option for USB but had the issue mentioned. Both the SUSE studio imagewriter (that comes with Manjaro) and Etcher on Win 10 produced a usb drive with no option to boot UEFI.

I then tried mounting the iso, copying all the contents to a freshly formatted USB stick (fat32). It has the UEFI boot option but immediately gives a message stating:

“Invalid magic number”

I am going to now try using dd from my Manjaro laptop. After that I am out of ideas :confused:

Hi @Zer0Cool,

you may change to legacy boot in BIOS instead of using UEFI…

I use e2b for USB booting and it works pretty well. Make an e2b USB stick, copy an ISO on it and just boot it.

http://www.easy2boot.com/

I use it for NethServer, Proxmox, ESXi, Windows and more, boots nearly everything:

http://www.easy2boot.com/add-payload-files/list-of-tested-payload-files/

And dd worked but gave me a stick that wont UEFI boot.

Honestly id prefer to do UEFI. I also could not find the legacy option in my MB BIOS, so either they named it something goofy, I missed it or its not there.

Ill check out the BIOS again, but I feel silly. Ive been at this for an hour and havent gotten the installer to start lol. Ive tried 4-5 different methods of creating the install media.

I know its likely me, but it cant really be this hard to create UEFI botable media…

Maybe ill try another USB drive, but ive used this one for dozens of various installs and never had an issue.

It’s also called secure boot or maybe compatible mode, you may try:

https://www.google.com/search?q=disable+uefi+in+bios

and go to pictures…maybe you can find your bios…

Secure boot <> UEFI. I already checked that secure boot was turned off. I have the manual from ASRocks site, gonna comb through it see what they called it.

In the mean time I may try another stick. I noticed Etched created a stick that appeared to only be ~900MB and gave me a ton of errors and odd behavior trying to reformat it and get it back to full capacity. A few other methods resulted in the same thing.

I use rufus at work to make UEFI bootable CentOS sticks all the time. Maybe ill just dig up my external DVD drive and burn the ISO to a disc

In some BIOSes when you go into boot menu you have the choice between UEFI and legacy…

OK, this should work as last possible solution…

Yea I have seen it a thousand times. Wana know what ASRock decided it should be called?

CSM

The cherry on top, the stylized it as a folder in the UEFI to take you into another menu with the options and explanation of what it actually is. So unless you selected it youd never know…

Never in my life have I seen such a stupid name for that feature. Ive seen legacy mode, compatibility mode, BIOS mode, etc. If I had the free time ASRock would be getting hate mail from me.

It was enabled, disabling it gave me UEFI boot option from the DVD drive i connected, installer running good now.

My guess, and I am gonna test it now, is my USB stick was fine using rufus. Booted as UEFI and the “CSM” being enabled conflicted with it.

1 Like

I’d guess so too, I used rufus and etcher without problems several times.

Rufus boot still fails. Gonna use DVD and move ahead to the next step. Thanks for the help, posting here and hearing back is likely the only thing that kept me from tossing the server out the window.

1 Like

Now I am unable to reclaim the SSD space and install to it. I get the dialog to reclaim space, select delete all and hit the reclaim space button. It kicks me back to the Installation summary. Under the Destination option it says briefly “failed to save storage configuration” then changes to “no disk selected”.

Going back in the SSD is selected but still showing some absurdly small amount of free space.

Technology hates me today…

This is anaconda centos installer, it’s known to be confusing sometimes…

Ive installed CentOS literally thousands of times on various hardware. Ive never seen this happen with reclaiming space (re: it not being able to). It seems to be unable to delete the previous partitions left by Windows Server. I didnt use any disk encryption, raid, etc prior.

Im scratching my head here. Havent found anything on Google about this either.

Wondering if I need to do something like boot gparted, wipe all the drives/partitions then run the installer? Any other ideas?

BTW, if I am coming across as grouchy, please know its not you guys…

Its been a long day and murphy’s law is in full effect here. I am just frustrated at myself for not having this go more smoothly.

Select “I will configure partitioning”

Expand the old partitions and delete them:

You are asked to delete all, say “Delete it”:

grafik

Expand "New centos installation and “click here to create them automatically” and “Done”.

That should work…anaconda centos installer is confusing sometimes, I had to try it several times…