Username is not displayed correctly (no UTF8?)

NethServer Version: NethServer 7.7.1908
Module: Cockpit

Hello,

I have a name which has some specific characters. These characters are not displayed in cockpit top right corner.

Complete name: Ertan Küçükoğlu

Cockpit visual:
image

Seemingly anything not in ASCII table is removed from display.

Is there anything I can do to fix this?

Thanks & regards,
Ertan

Hi @ertank,
may I ask you which is the nationality of your name?
IMVHO should be not user-workable this issue, but, maybe Dev Team may report to Cockpit Project.

Or the “default config” of Cockpit should be changed…

Hello, It is a Turkish name.

cc @dev_team

what account provider do you use, nethserver-dc (SAmba AD) or nethserver-directory (openldap)

As far I know, we have validators that block username not ascii

It is openldap server.

Problem is not username, top right corner, it is “Name” displayed.

I intentionally use ascii characters on username.
image

Name, I write as in its original, and see just as I typed in user list.

I also find it just fine when I “edit”
image

It is only removed from non-ascii characters on top right corner.

BTW, I failed to login using a regular user (just the above one I created for test purposes). I see below in /var/log/messages

May 12 09:53:11 neth cockpit-session: pam_ssh_add: Failed adding some keys
May 12 09:53:11 neth systemd: Created slice User Slice of ascii_username@greenkey.com.
May 12 09:53:11 neth systemd: Started Session 45 of user ascii_username@greenkey.com.
May 12 09:53:11 neth systemd-logind: New session 45 of user ascii_username@greenkey.com.

On browser, I only see below:


After sometime about 30 seconds I see on browser

Authentication failed: Timeout

and on /var/log/messages

May 12 09:53:41 neth cockpit-ws: cockpit-session: session timed out during authentication
May 12 09:53:41 neth cockpit-ws: cockpit-session: authentication timed out
May 12 09:53:41 neth systemd-logind: Removed session 45.
May 12 09:53:41 neth systemd: Removed slice User Slice of ascii_username@greenkey.com.

I can login just fine using root user.

Just for the record, I am behind a Squid Proxy server if that makes any difference.

for the timeout, check the user has a shell access (advanced menu of the user), you have a checkbox

Relative to UTF8 caracters, we have no validators for the gecos (Name), therefore you are not limited to use what you want but maybe cockpit does not use it well

in /usr/libexec/nethserver/api/system-users/validate:

$v->declareParameter('gecos', Validate::NOTEMPTY);
1 Like

I can reproduce the bug, updating a user with ü in gecos (long name of the user : firstname lastname), it is not displayed in the upper right corner

@edoardo_spadoni can we do something or it is an upstream bug ?

The upper right corner is not controlled by us, it’s upstream. So yes it’s an upstream bug.

2 Likes

I don’t think it is an upstream issue.

The gecos field charset is filtered in the user-create event

Let’s call 911 :slight_smile: http://dev.nethserver.org/issues/911

Interesting commit note (7 yrs ago):

Note: a validator must be implemented on UI modules.

1 Like