Upgrade-problem sogo4 at neth7

sogo
v7
migration

(RoWiHei) #1

**NethServer Version: 6.9 **
**Module: sogo2.3.10, owncloud7 **

currently

  • Firewall (iPFire) with 4 LANs: green + blue + orange + red
  • nethserver 6.9 as Mailserver in orange LAN (DMZ) with SOGo2.3.10 and ownCloud7
  • nethserver is stand-alone as workstation (not a member of AD…)

goal is to upgrade to nethserver7 with sogo4 and nextcloud
So I tried this under proxmoxVE with virtual machines.

after
screen rsync-upgrade -u 10.2.2.9 2222
and
signal-event post-restore-data
It looked good, at the first, BUT …:

under Status > Mail quota :
you can see the “old (sogo2.3.10) email-accounts” and the “new email-accounts

user						 Size	   Max.Size
________________________________________________________
admin                                          65MB	  2GB
**admin@xy-systeme.de           	-	  2GB**
user1						10GB	30GB
**info@xy-systeme.de	        	-	  2GB**

Problem:
How can I move the content of the mailboxes to the new structure ?
Is there a script or at least a tutorial ?

Thanks for every tip !


(Rob Bosch) #2

I migrated my mailserver from an Ubuntu based VPS to a NethServer7 based VPS and used imapsync to move all the mails.
I installed imapsync on the ‘old’ server and moved all mail data to the new (NethServer) server. Quite straighforward.
Some more info in our wiki: https://wiki.nethserver.org/doku.php?id=imapsync&s[]=imapsync


(Michael Träumner) #3

You can also have a look at

/var/lib/nethserver/vmail/Maildir

and copy the content from old mailbox to new one.


(Giacomo Sanchietti) #4

The rsync-upgrade copies all data.


(RoWiHei) #5

Thank you very much,

I tried imapsync and after some mistakes now it is importing the mailes … I have to wait, because there are ~16000 and more mails.
But I don’t understand, why rsync-upgrade only copied all email-folders to neth7, without advice.
I’m a little bit disappointed.
I hope, after this imapsync there is enough space on neth7…
… Now imapsync break because more then 50 errors. I never thought that this would be so much stony…
Thanks anyway!


(RoWiHei) #6

The problem is: because there is another mail-server on neth7 with another structure as in neth6.
That’s why I can’t see mails in sogo4/neth7…
There have to be more steps to real MIGRATION.
Rsync-upgrade only copies structures/files from neth6 to neth7 without conformation


(RoWiHei) #7

Thanks,m.traeumer,
this I tried before.
But without success, something like " error in mail system "

Sorry, it was my mistake - I have to copy/move only the maildirs ! NEVER COPY files dovecot.*
But this method is only reasonable if there are less email-accounts on mailserver.
… new problem:
I found no way to define mail quota - Example:
on neth6 was a user1 (name Max Muster). His account had mail quota 20GB!
After upgrade to neth7 I have to move his emails from folder /var/lib/nethserver/vmail/user1 to folder /var/lib/nethserver/vmail/max.muster@xy-systeme.de. 16000 emails with 15GB
But on dashboard I find the account max.muster@xy-systeme.de only as mail alias and there is no chance to define mail quota.
Now it’s not possible to use this mail account (only look to old emails) … because of content > 2GB.
How can I correct this ?


(Markus Neuberger) #8

The mail alias should have a destination which is a user mailbox. You can define a quota for a user mailbox:

grafik

http://docs.nethserver.org/en/v7/mail.html?highlight=quota#mailbox-configuration


(RoWiHei) #9

Hallo, mrmarkuz,

this mask on dashboard I know… BUT…
after upgrade neth6 >> netht7 I only found user1 (neth6-username) in this list with 20GB mailbox quota.
But max.muster@xy-systeme.de only found on tab Mail aliases. Please look on this tab - there is no chance to define mailbox quota for the mail aliases.
Sogo shows sadly the boxes of mail aliases…


(Markus Neuberger) #10

Maybe I am missing something but couldn’t you just define a destination and set your user, then login to sogo with that user.


(RoWiHei) #11

Hallo, Markus,

think this is a “special effect” of upgrade neth6-workstation —> neth7-LDAP-server
Sadly it is not possible to create neth7-workstation without LDAP/AD…

on neth6 there is under Management >> Email-addresses this list:

Email… Account…Attributes…Actions
info@xy-systeme.de…user3…–
max.muster@xy.systeme.de…user1…–
on neth6 under Management >> Users >> Services I defined custom mailbox quota of 20GB for user1.
After rsync-upgrade to neth7 under Management >> Email addresses > User mailboxes now found
User…custom mail quota. . . .
user1@xy-systeme.de … 20GB
user3@xy-systeme.de… …3GB
and under Management >> Email addresses > Mail aliases
Alias… … … … … … … … … … … … Destinations
max.muster@xy-systeme.de… … user1@xy-systeme.de … … …
info@xy-systeme.de… … … … … user3@xy-systeme.de … …

and under Status >> Mail quota
User… … … … … … … … … … … … Size … Max.size
max.muster@xy-systeme.de … … 15,36GB … 2GB
user3@xy-systeme.de … … … … …2,17GB …3GB

user1=Max can see all emails under sogo, but with red warning " usage … 767% "
user3=info can see NO emails after sogo-login ???

It’s a mystery … Now I think there is no automatic update possible in my situation.
Next I start from the beginning and create manually user1 with email max.muster@~, quota 20GB,
and try to import emails with imapsync from neth6…
On the Neth6-Server exist at the moment 25 users … …