Unable to access FQDN on local network

firewall

#1

I am unable to access my FQDN on the local network. when I try to connect I get Connection Timed Out Error. Outside the local network I can access the server and all services. my only thought is that the /etc/resolv.conf does not list any nameserver other than localhost. See my settings below:


#2

For one, it looks like you have both adapters, eth0 and eth1 on the same subnet.


(JamesMillar) #3

Centos does not like having two ethernet adapters on the same segment. It even complains about two adapters connected to the same switch if on separate segments. Either unplug one or bond them, otherwise you will encounter very strange issues.


#4

I have changed the IP Address of eth1 to the public IP issued by my Internet Service Provider. I am now able to access the server using the fully qualified domain name

The ip address in the picture is not my real ip just for reference


(Alessio Fattorini) #5

Then is it solved? :wink:


(Artem Fedai) #6

I suggest that topic like this should be Deleted or make please New category SOLVED


#7

Unfortunately my problem has not been solved. With the public ip address from my Internet service provider entered into eth1 I get no route to host error on all incoming emails in /var/log/maillog


(Artem Fedai) #8

what about DNS names and ip address, is your IP static ?
ping 199.181.32.250
PING 199.181.32.250 (199.181.32.250) 56(84) bytes of data.
^C
— 199.181.32.250 ping statistics —
5 packets transmitted, 0 received, 100% packet loss, time 5002ms


#9

The 199.181.32.250 is not my real public ip address. Could someone share their configuration with a public static ip address in NethServer? My ISP is Comcast.

Oct 5 15:05:06 myhostname default/smtp[4088]: connect to miamigardensfl-gov03b.mail.protection.outlook.com[207.46.163.215]:25: No route to host


Oct 6 01:25:07 myhostname postfix/qmgr[2600]: 19F821C1AF8: from=user@mydomain.com, size=140372, nrcpt=2 (queue active)
Oct 6 01:25:27 myhostname default/smtp[11066]: 19F821C1AF8: to=user@gmail.com, relay=none, delay=46579, delays=46559/0.05/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=gmail.com type=MX: Host not found, try again)

Pardon me not posting my hostname and real ipaddress, the system is in production and I cannot afford for it to be compromised.


#10

I just checked my /etc/hosts file and I do not see my public ip address listed there. should i create a custom template for the 30hosts_remote section?


(Davide Principi) #11

Public IP should be in public DNS? Why you need to resolve it locally?


#12

The email client is configured to use the fully qualified domain name


#13

That’s a dns issue with your nethserver.

[root@server9b ~]# nslookup gmail.com
Server:         192.168.148.2
Address:        192.168.148.2#53

Non-authoritative answer:
Name:   gmail.com
Address: 216.58.216.5

post your nslookup.


(Artem Fedai) #14

Problem inMX record for your domain it should be resolved for your Pub IP


(JamesMillar) #15

Are you hosting your own mail server that requires you to add a MX record?


(Artem Fedai) #16

Yes of cource !!! With out MX all mail server will reject you


(JamesMillar) #17

So you have a local mail server serving people and clients? I’m trying to understand your setup and why you’re unable to access your local FQDN. My NS servers are capable of emailing me but that doesn’t require a MX record. I don’t even use the DNS module in NS.


#18

My set up:

  • Domain Controller
  • Email Server
  • OwnCloud

#19

We can’t help you if you insist on being terse and cryptic.

Do you not wish to post your nslookup output?

A network map?

ie; internet - modem - (ext ip) NS ( DC, DNS server, DHCP server, email, oC) (int ip) - switch - nodes (clients). ???

As Jerry McGwire said; “Help me, help you!”


#20

sorry for the criptic-ness
ISP Comcast
external IP - 173.9.XXXX

Inside the office there are 6 windows 7 PCs that connect to the domain.

The server is plugged directly into the Comcast Modem/Router Combo Device. There is a switch in the office that the other computers are plugged into