Try out Nethserver 7 RC1

Here again!
as you know we need your help to make NethServer 7 the best release yet, so please take some time to download and try out the RC1 and make sure the things that are important to you are working.

  • You can install it on a virtual machine or on a bare-metal server using a DVD or USB stick
  • Upgrade from Beta 2 is supported through the Software center

If you find a bug, please report it replying to this topic – every bug you uncover is a chance to improve the experience for thousands of NethServer users worldwide!


I’m having issues trying to connect to Samba file shares on RC1, installed in a VM on ESXi. Everything appears to be in place, but I just can’t connect to port 139 in the server.

On the server (Green:, Red:

[root@Nethserver-Beta ~]# ps -ef | grep mbd
root      6318     1  0 00:25 ?        00:00:01 /usr/sbin/nmbd
root     25623  8481  0 10:38 pts/1    00:00:00 grep --color=auto mbd
root     26828     1  0 Oct19 ?        00:00:00 /usr/sbin/smbd
root     26830 26828  0 Oct19 ?        00:00:00 /usr/sbin/smbd
root     31393 31383  0 00:06 ?        00:00:00 /usr/sbin/smbd -D --option=server role check:inhibit=yes --foreground
root     31406 31393  0 00:06 ?        00:00:00 /usr/sbin/smbd -D --option=server role check:inhibit=yes --foreground
root     31407 31393  0 00:06 ?        00:00:00 /usr/sbin/smbd -D --option=server role check:inhibit=yes --foreground
root     31427 31393  0 00:06 ?        00:00:00 /usr/sbin/smbd -D --option=server role check:inhibit=yes --foreground
[root@Nethserver-Beta ~]# netstat -an | grep 139
tcp        0      0 *               LISTEN
tcp        0      0*               LISTEN
[root@Nethserver-Beta ~]# netstat -an | grep 138
udp        0      0*
udp        0      0*
udp        0      0   *
[root@Nethserver-Beta ~]# netstat -an | grep 137
udp        0      0*
udp        0      0*
udp        0      0   *
[root@Nethserver-Beta ~]# arp -n
Address                  HWtype  HWaddress           Flags Mask            Iface              ether   00:1f:c6:e4:9d:96   C                     ens160            ether   00:25:90:a6:75:d1   C                     ens160               ether   00:0c:29:2c:47:e0   C                     br0              ether   02:8c:70:99:03:4b   C                     br0               ether   00:0c:29:c5:73:3c   C                     br0
[root@Nethserver-Beta ~]# arp
Address                  HWtype  HWaddress           Flags Mask            Iface              ether   00:1f:c6:e4:9d:96   C                     ens160            ether   00:25:90:a6:75:d1   C                     ens160
Deepest-Thought.BogoLin  ether   00:0c:29:2c:47:e0   C                     br0              ether   02:8c:70:99:03:4b   C                     br0  ether   00:0c:29:c5:73:3c   C                     br0
[root@Nethserver-Beta ~]

And from another Linux box (

And from a Windows box (

Windows seems to see the server, which if memory serves me correctly, is achieved via the UDP ports:

EDIT: Forgot this:

I also checked the firewall.log on the server and only see entries from when I tried a telnet (port 23) and ftp. Nothing for smb (139).

Ideas on what to check next.


From the gui;

What’s in Trusted Networks?
What’s in Network Services?
And then Services?

Have you created a share? Can win 10 see it?

Trusted networks:
Network services: nmb (NetBIOS)/UDP: 137,138/ACCEPT: green
Services: nmb (NetBIOS)/Enabled Running/UDP: 137,138

Guess that explains it. No smb service.

Yes, there is a share, but it can’t be seen remotely because nothing can connect.

How do I activate the smb service. Or more concerning, why wasn’t it automatically created.

** EDIT ** I just checked in the configuration db:


** Yet more EDITs ** Just found this message in the logs: [INFO] smb is not configured: skipped



Wait, you don’t have an smb service? It should be part of File Server. If you’ve created a share, allowed read and it’s browseable then it should be up. Has the server been rebooted since install of File Server?

If this is the case, this is the first we’ve heard of this issue. Did you install Samba AD?

Yes I had re-booted, but just did so again to be 110% certain. BTW The last 2 reboots have both “stalled” after the [OK] Reached target Shutdown.

And yes, I’m using Samba AD.


Maybe it is a silly question, but the database contains this?

or is a typo (sevice)?

Good spot. That was a cut/paste, so yes, the db does contain that. :confounded:

Let me edit, reboot and see what happens.


OK, now we’re getting somewhere.

I updated the db to have service correctly spelt, and re-booted. Yeah, yet again the shutdown stalled after showing: [OK] Reached target Shutdown.

Now smb shows up in Services :grinning:, but in Network Services:

A quick edit to switch it to ‘Green’ and away we go:

Now the question is, where is my home directory, as that is also supposed to be available.

EDIT Fixed. I needed to sign in to one of the shares, and then magically my home directory appeared.



Why are you editing the db?
That’s not really in keeping with the philosophy around the gui and the distro.

Are you suggesting I should have left it as: smb=sevice.

The only edit I did was to correct it to: smb=service


Ah, I misunderstood copy/paste … we need to figure out why that entry was created incorrectly I think. @davidep ?? Is this a thing?

1 Like

OK, I guess I need to raise my hand here, and hang my head down. :anguished:

It was my mistake all along. When I was configuring the Samba AD domain, I noticed I couldn’t update the NetBIOS name in the UI and after looking at the manual found the instructions to do so as a command:

config set smb service Workgroup <your_netbios_domain>

The only problem is, I manged to mangle “service” as “sevice” when typing it in. :sob:

Sorry for all the confusion caused here.



No worries, now the mistery is cleared out :sweat_smile:

I have the same problem too with my VM (KVM/fedora24)… Does anybody else reproduce it too? /cc @quality_team

I have the same problem with NS7b2 (dedicated HW), even I have upgraded it to NS 7RC1.

I don’t know when appeared the problem. Is for testing and I have installed on it all testing modules.

With NS 7RC1 installed from ISO (dedicated HW), I don’t have this issue till now (there are other :wink:).

1 Like