Trouble setting up a mail server with dynamic dns


(Luciano Vicentini) #1

I’m having trouble setting up a mail server with dynamic dns.


Try out NethServer 7 alpha2 ISO!
Try out NethServer 7 alpha2 ISO!
Try out NethServer 7 alpha2 ISO!
(Artem Fedai) #2

Hi, what kind of trouble ?


(Luciano Vicentini) #3

Hello @Nas I installed NS and tried to set up a mail server for domain managed by zoneedit.com. Tested various configurations and not hit one yet. I do not send or receive external email. I found here in the forum some tips but not yet solved the problems. Maybe I’m doing it all wrong.


(Artem Fedai) #4

Have you pointed MX record on your DDNS provider?


(Jose "Martin" Abeleira. AKA Marto) #5

Are you behind a router, if so ports are forwarded? did you tried to
manually conect to smtp server usign the dynns addresss or the ip address
via telnet and send an email?


#6

you need ddns? does your isp block p 25?


(Luciano Vicentini) #7

No router, DNS will be the router, mail server, dns server, dhcp server, domain controller. The modem is straight to the NS server.


(Artem Fedai) #8

Make port forward on modem to 25 port of Nethserver


(Jose "Martin" Abeleira. AKA Marto) #9

did you tried to telnet port 25? Are you trying to access the server from
internal or external network? to which ip is you client resolving?


(Luciano Vicentini) #10

My modem is briged mode.


(Jose "Martin" Abeleira. AKA Marto) #11

Send us the dns so we can try to connect to pop or smtp


(Luciano Vicentini) #12

http://www.evops.com.br and mail.evops.com.br


(Jose "Martin" Abeleira. AKA Marto) #13

Seems not resolvable

[ ~]$ telnet mail.evops.com.br 25
mail.evops.com.br: No address associated with name
[ ~]$ ping mail.evops.com.br
ping: unknown host mail.evops.com.br
[ ~]$
[ ~]$ ping mail.evops.com.br
ping: unknown host mail.evops.com.br
[ ~]$ dig mail.evops.com.br

; <<>> DiG 9.4.1 <<>> mail.evops.com.br
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41696
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;mail.evops.com.br. IN A

;; AUTHORITY SECTION:
evops.com.br. 1752 IN SOA dns0.zoneedit.com.
zone.zoneedit.com. 1456163364 3600 600 604800 10800

;; Query time: 38 msec
;; SERVER: 200.40.220.245#53(200.40.220.245)
;; WHEN: Wed Feb 24 16:54:01 2016
;; MSG SIZE rcvd: 93

[ ~]$ nslookup mail.evops.com.br
Server: 200.40.220.245
Address: 200.40.220.245#53

Non-authoritative answer:
*** Can’t find mail.evops.com.br: No answer

Seems that you don’t have your dns set correctly, and you might need to
open those ports in the firewall of the ns.

[ ~]$ ping evops.com.br
PING evops.com.br (189.33.83.202) 56(84) bytes of data.
64 bytes from bd2153ca.virtua.com.br (189.33.83.202): icmp_seq=1 ttl=54
time=110 ms
64 bytes from bd2153ca.virtua.com.br (189.33.83.202): icmp_seq=2 ttl=54
time=104 ms
64 bytes from bd2153ca.virtua.com.br (189.33.83.202): icmp_seq=3 ttl=54
time=98.4 ms
64 bytes from bd2153ca.virtua.com.br (189.33.83.202): icmp_seq=4 ttl=54
time=98.5 ms


(Eddie Atherton) #14

and you DO need to open those ports in the firewall of the ns

Or your ISP is blocking them.

>telnet 189.33.83.202 25
Connecting To 189.33.83.202...Could not open connection to the host, on port 25:
 Connect failed

Cheers.


(Luciano Vicentini) #15

Oh sorry, in this moment I am upgrading the NS server. It is down. Sorry man.


(Rob Bosch) #16

This conversation has some trouble getting started properly.
@lvicentini, please provide ALL relevant information. We can not help you properly if we have t guess what you tried to configure and what the result of that was.

I understand you want to use Zoneedit as a dyndns service because you have a dynamic IP address from your internet provider.
You have registered a domain name: evops.com.br and want to use that for the webservices on your home internet connection.

First thing we need to know is: do you have your domain already registered with zoneedit?
When you have registered your domain with zoneedit, you can create records for it.

If you want to use the mail server options, make sure your provider has not blocked port 25 for mail. Many consumer internet lines are blocked for mailservers. Alternatively use the smtp smarthost of you internetprovider.

So please, provide all the info first. Our glass bowl is a bit foggy… :frowning:


(Filippo Carletti) #17

I can reach a NethServer login page on port 980 of evops.com.br, but email ports seem closed (I can’t reach port 25 or 587).
Port 465 is open.
I think that Claro blocks smtp:
http://www.cert.br/docs/palestras/certbr-citel-itu-isoc2013.pdf


(Luciano Vicentini) #18

Okay @robb, I am sending information relating to the ZoneEdit. Thanks for your help.
Registration Domain Screen.

Dynamic Domain Screen.

CNAME records Screen.

MX records Screen.


(Rob Bosch) #19

Thank you for the info. From @filippo_carletti we already saw that the DNS redirection is working. But the smtp part (port 25) not since that port is not open.
Did you open smtp port in NS firewall?
Did you ask your provider if private smtp is allowed? If not, you should use the smtp smarthost to send your emails.


(Eddie Atherton) #20

But not for mail:

[eddie@NethServer ~]$ ping mail.evops.com.br
ping: unknown host mail.evops.com.br
[eddie@NethServer ~]$ ping evops.com.br
PING evops.com.br (189.33.83.202) 56(84) bytes of data.
64 bytes from bd2153ca.virtua.com.br (189.33.83.202): icmp_seq=1 ttl=46 time=205 ms

For that to work, there needs to be a CNAME entry for mail.evops.com.br.

But the bigger issue appears to be that port 25 is blocked.

Cheers.