Tomcat doesn't work from network


(Enrico Lorenzi) #1

Hi I have an issue with tomcat 7. I installed centos with gnome from livecd and nethserver afterwards from command line.
After install all packages, I added tomcat 7 and phpmyadmin and works both from any pc on my network.
Restarting the server I discoverd an issue with network that was down and I need manually to reset it after every startup, so I made a network reset following the guide and everythings seems to be ok with that, but I had 2 issues with mariadb and tomcat. After reinstalled mariadb from panel it start works again but no way with tomcat, it works fine from console but noway from network, Tried to reinstall several times, delete config file but no way.
Any idea ?


(Filippo Carletti) #2

Forgive me for asking, but what is a network reset? What guide did you follow? Could you share some links or post here the commands?


(Enrico Lorenzi) #3

Hi Filippo, I followed this guide on Reset Network Configuration chapter
http://docs.nethserver.org/projects/nethserver-devel/en/v7/nethserver-base.html#reset-network-configuration


(Markus Neuberger) #4

Hi @enrilor,

I assume it’s blocked by the firewall. You may install nethserver-tomcat. It configures shorewall to open port 8080 to the green network.


(Enrico Lorenzi) #5

That’s what I originally thought me too, but I don’t think that this is the problem. I tried to install basic firewall, and 8080 is open, remove Tomcat and install webtop that include Tomcat but same problem.
I don’t know if it’s possible but I think that Tomcat is not allowing access to new network interface.
Anyway I gonna try your suggestion later.
Thanks for help.


(Enrico Lorenzi) #6

It works, thanks very much.


(Markus Neuberger) #7

You’re welcome. Please mark the answer that helped you as solution to close the topic and help people with similar problems to find it easier.