Timezone not set properly on a new install


#1

Suite du sujet PB with timezone in the dashboard and disk usage:

With a fresh new install, in the CLI

#Config getprop php DateTimezone
UTC
#config show TimeZone
TimeZone=America/Belem

This after the first configuration wizard… :smirk:
It’s a bug, isn’t it?


(Giacomo Sanchietti) #2

I will check it.


#3

I was browsing issues on the Nethserver dev site.
There 's nothing about this issue…

I’m the only one this issue happen?


(Giacomo Sanchietti) #4

Just checked, but I can’t reproduce the problem.
Tested with Rome and Belem timezone: the configuration is always consistent.

For reference:

[root@localhost ~]# cat /etc/sysconfig/clock 
# ================= DO NOT MODIFY THIS FILE =================
# 
# Manual changes will be lost when this file is regenerated.
#
# Please read the developer's guide, which is available
# at https://dev.nethesis.it/projects/nethserver/wiki/NethServer
# original work from http://www.contribs.org/development/
#
# Copyright (C) 2013 Nethesis S.r.l. 
# http://www.nethesis.it - support@nethesis.it
# 
ZONE="America/Belem"
UTC=true
ARC=false
[root@localhost ~]# config show TimeZone 
TimeZone=America/Belem
[root@localhost ~]# config show php
php=configuration
    AllowUrlFopen=1
    DateTimezone=America/Belem
    ExposePhp=0
    MaxExecutionTime=30
    MemoryLimit=32
    PostMaxSize=8
    ShortOpenTag=0
    UploadMaxFilesize=2

#5

Perhaps the pb is in other place …
I had made my installation with a minimal CentOs (I choose the correct TZ here)
and after, I’'d made the Nethserver Installation…

I’m not proceding with the standart Cd-rom installation cause of no cd-rom


(Stefano) #6

create a VM, start from minimal centos and test NS setup, checking if everything is working as expected…

then setup NS in a VM starting from iso and check again…

virtualization is there mainly for testing… and setup a VM is a matter of 5 minutes…


#7

Sorry to insist, but perhaps there’s only a problem of interpretation:

When I said this:

@giacomo answered :

At this point, I understood that UTC is not the correct Timezone.

Also:

Is not correct… Or I missed something?


(Giacomo Sanchietti) #8

It is correct: it refers to hardware clock.

See:


#9

Now that I’ve got a new fresh VM working :smiley:
The first test is this timezone… That’s not set properly by the configuration wizard:


#10

Heu…
I found the “issue”.
Installing by the Minimal CentOS way, when choosing the TZ, by default there a selected option “use UTC”.
When making the installation without this option, all is okay :wink: