Third Party (ELREPO) Drivers And Nethserver

NethServer Version: v7RC3
Does anyone have any experience with loading “elrepo” drivers into nethserver (more specifically kmod-forcedeth driver). My experience is it seems to work well with CentOS 7.3, but seems to kill DNS with Nethserver.

I see some comments on elrepo that their drivers won’t always work with “distributions known to break kernel ABI compatibility”.

I’ve tried installing a couple of different ways:

  1. Nethserver then driver,
  2. CentOS, then driver, then “nethserver-install”

Configuration of DNS from Nethserver web interface looks good, and “services” reports dnsmasq is running.
IP address based connections are fine.

ping: Name or service not known

I use some elrepo ethernet drivers on different servers without problems.
Honestly, I never used forcedeth, but I don’t think the DNS is linked to a driver in any way.
The order of installation shouldn’t matter.
To diagnose DNS issues, try with:
grep server= /etc/dnsmasq.conf
You should see the DNS you have configured.


Thanks for the feedback. If the elrepo driver should work with nethserver, then I think there is a bug somewhere.

 [root@server02 ~]# grep server= /etc/dnsmasq.conf
 # server=10.1.2'.3@eth1
 # server=

(Single quote prepended to avoid formatting issue in this post)

Nethserver admin shows DNS is configured correctly.

Steps to reproduce issue are:
Install sequence.

  1. Base CentOSv7.3 system, install, reboot
  2. Install Ethernet driver (yum install kmod-forcedeth…) and reboot
    ping - OK
  3. yum update, and reboot
    ping - OK
  4. yum localinstall -y
    ping - OK
  5. nethserver-install
    ping - ERROR - cannot resolve
  6. run ‘first install’, and reboot
    ping - ERROR - cannot resolve
  7. Manually update DNS from Nethserver web interface, reboot
    ping - ERROR - cannot resolve

If the install process is repeated on a VM without the driver install, then nothing breaks.
Yet from the above steps, installing CentOS with the driver and updates but no nethserver, then nothing breaks either.

Presumably I can manually add in server= and things might start working, but a subsequent change to the DNS settings from Nethserver will then not work.

There’s no obvious error messages in the log files

Anything else I can check?

1 Like


Just looked at /etc/dnsmasq.conf rather than just grep’ing it.
The dnsmasq.conf file is NOT getting overwritten with the nethserver templated one.
Part of install/config fails maybe??

1 Like

Maybe :slight_smile:

Let’s if dnsmasq is correctly installed:

rpm -q nethserver-dnsmasq

If installed, try to re-execute the update event:

signal-event nethserver-dnsmasq-update

1 Like

Thanks for suggestions Giacomo.
Here’s output from your suggestions.

[root@server02 ~]# rpm -q nethserver-dnsmasq

[root@server02 ~]# signal-event nethserver-dnsmasq-update
[root@server02 ~]#
(ie no error returned)

vi /etc/dnsmasq.conf
’# Configuration file for dnsmasq.
’# Format is one option per line, legal options are the same
’# as the long options legal on the command line. See
’# “/usr/sbin/dnsmasq --help” or “man 8 dnsmasq” for details.

ie file still not changed.
Anything else to try ??

A little hint to add into documentation for update/upgrade, @docs_team: notify that if an installation is using elrepo driver for a network adapter (like my test-install) this card could possibly not be available during part of the update process.

In fact, this card disappeared after an update/upgrade to 7.4. Luckily, another interface was available so was able to reconfigure as red interface, therefore after another update-process the interface was again available.

1 Like