3 network cards hardware, only 2 on admin interface

Hi pals,
on my tiny-and-useless-test server there are 3 network cards
lspci |grep Ethernet 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03) 03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16) 04:05.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 05)

but only two are showed and configurable on admin interface
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::20a:cdff:fe1e:7888 prefixlen 64 scopeid 0x20<link>
ether 00:0a:cd:1e:78:88 txqueuelen 1000 (Ethernet)
RX packets 4731 bytes 552884 (539.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3690 bytes 2630341 (2.5 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

enp3s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 ether 90:fb:a6:85:31:ba txqueuelen 1000 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 device interrupt 17

(loopback deleted)
The missing interface is an old 10/100 PCI network card, but for connections to DSL routers should be “enough”.

It’s a by-design-choice not supporting these cards?

NS hw support depends on kernel…
So you’d check if that nic is in RH/centos hcl


Looks like this problem: http://superuser.com/questions/841264/issues-with-network-interface-card-in-centos-7
You need drivers for the Intel 100Mb interface:

When I installed the operating system I found I were missing two NICs from network manager and when we used the command:

~] # lspci -k -nn | grep -i ‘ethernet’

I found out that we have the card installed but they were not
performing the task. Both of them were of same king and it was obvious
that these routers were missing drivers, I tried to search for drivers
and found the drivers on elrepo and the driver name was kmod-e100. I
tried installing it using:

~] # yum install kmod-e100

but it didn’t work and after more research I found out that to
install this driver you have to declare the repositories by using this

~] # rpm -Uvh http://www.elrepo.org/elrepo-release-7.0-2.el7.elrepo.noarch.rpm
and now when I used the same yum command it worked.


And @robb played the right trick.
Using these commands
rpm -Uvh http://www.elrepo.org/elrepo-release-7.0-2.el7.elrepo.noarch.rpm yum install kmod-e100
enp4s5 appeared like a vision. And worked too, whick is good, because is the red interface for my little scapegoat.

Thanks for the help.