Testing NethServer 7.5.1804 alpha

Yes there’s a nethserver-release update named “beta”. However consider it still “alpha” until we turn the symbolic link in repository from 7 -> 7.4.1708 to 7 -> 7.5.1805!

… here http://packages.nethserver.org/nethserver/

1 Like

3 hours are a looong time these days :stuck_out_tongue:

I confirm that groups metadata should be ok, this is the actual file.
By the way everything should be simpler to test when we switch the directly to 7.5.

Another great catch: it doesn’t have side-effects but the migration procedure will be marked as failed. I’m going to remove it, thank you!

1 Like

i have some problem with email(2) and sogo, those are my installation steps

Install 7.5a2 in interactive mode (dhcp), then

# yum install yum-utils -y  && yum-config-manager --enable nethserver-testing
# mkdir -p /etc/e-smith/templates-custom/etc/yum/vars/nsrelease/ && echo 7.5.1804 > /etc/e-smith/templates-custom/etc/yum/vars/nsrelease/00version_lock && expand-template /etc/yum/vars/nsrelease
# yum -y install htop mc iotop iptraf iftop bash-completion bash-completion-extras mlocate && updatedb
# yum clean all && rm -rf /var/cache/yum

webui:
firstwizard

some errors in logs:
illegal attempt to update using time 1526542587 when last update time is 1526549754 (minimum one second step)

SoftwareCenter -> Update: no error, new kernel, so reboot (webwirt manager present)
after reboot:
SoftwareCenter > 	Update: no update
					WebVirtManager: present
					Install: Email+disclaimer, Pop3 Connector, SMTP proxy = no errors in webui
					on logs: 	systemd: Failed to start clamd scanner (rspamd) daemon.
								systemd: Unit clamd@rspamd.service entered failed state.
								systemd: clamd@rspamd.service failed.
reboot, now clamd@rspamd.service is active
SoftwareCenter > 	Update: no update
					WebVirtManager: present
					Install: Sogo
					on logs:	 esmith::event[3376]: ERROR 1146 (42S02) at line 1: Table 'sogo.sogo_folder_info' doesn't exist
								 esmith::event[3376]: Action: /etc/e-smith/events/nethserver-sogo-update/S30nethserver-sogo-MigrationV3.2.10ToV4.0.0 FAILED: 1 [0.684798]
								 esmith::event[3376]: Event: nethserver-sogo-update FAILED
					on webui: error img

just to be sure, i will try to replicate…

1 Like

This is a collectd warning, it happens often in many installations.

It seems you’re not accessing the latest repositories, the sogo error has been fixed and the rpm is available here.

Bear in mind you should fix all repos to 7.5.1804: https://github.com/NethServer/nethserver-release/#locking-to-a-specific-distribution-release

About the error on mail server, I will try to reproduce it.

1 Like

i think the steps i do after install should lock me to 7.5.1804

# yum info nethserver-sogo
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
 * base: mi.mirror.garr.it
 * epel: ftp.wrz.de
 * extras: mi.mirror.garr.it
 * updates: mi.mirror.garr.it
Available Packages
Name        : nethserver-sogo
Arch        : noarch
Version     : 1.7.2
Release     : 1.ns7
Size        : 47 k
Repo        : nethforge/7/x86_64
Summary     : NethServer SOGo configuration
URL         : http://github.com/NethServer/nethserver-sogo
License     : GPL
Description : NethServer SOGo configuration


# yum repolist 
Loaded plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
 * base: mi.mirror.garr.it
 * epel: ftp.wrz.de
 * extras: mi.mirror.garr.it
 * updates: mi.mirror.garr.it
repo id                                          repo name                                                           status
base/7/x86_64                                    CentOS-7 - Base                                                      9,911
centos-sclo-rh/x86_64                            CentOS-7 - SCLo rh                                                   7,050
centos-sclo-sclo/x86_64                          CentOS-7 - SCLo sclo                                                   521
epel/x86_64                                      Extra Packages for Enterprise Linux 7 - x86_64                      12,542
extras/7/x86_64                                  CentOS-7 - Extras                                                      258
nethforge/7/x86_64                               NethForge 7                                                             22
nethserver-base/7/x86_64                         NethServer-7 - Base                                                    288
nethserver-testing/7/x86_64                      NethServer-7 - Testing                                                   3
nethserver-updates/7/x86_64                      NethServer-7 - Updates                                                   0
updates/7/x86_64                                 CentOS-7 - Updates                                                     15

or in repolist -v
Repo-id : nethserver-testing/7/x86_64
Repo-name : NethServer-7 - Testing
Repo-revision: 1526547781
Repo-updated : Thu May 17 11:03:02 2018
Repo-pkgs : 3
Repo-size : 106 M
Repo-mirrors : http://mirrorlist.nethserver.org/?release=7&repo=testing&arch=x86_64&nsrelease=7.5.1804
Repo-baseurl : http://packages.nethserver.org/nethserver/7.5.1804/testing/x86_64/
Repo-expire : 21,600 second(s) (last: Thu May 17 12:28:44 2018)
Filter : read-only:present
Repo-filename: /etc/yum.repos.d/NethServer.repo

for nethforge:
# rpm -qa nethserver-nethforge-release
nethserver-nethforge-release-7-1.ns7.noarch

probably i’m missing something… :thinking:

edit: new vm, same steps now there is no webvirt :thinking::smirk:

Please ensure your NethForge.repo file has been updated with latest change that fixes the “nsrelease” variable:

https://github.com/NethServer/nethserver-nethforge-release/pull/1/files

It’s required by “locking-to-a-specific-distribution-release” procedure

1 Like

yes, there had to be some problem with the repo (even if I do not understand why,I use the same procedure) now seems to be all ok both with mail (2) and with sogo (and webvirt)
I’m sorry to have wasted your time :pensive::innocent:
step to test other

No waste at all! Double check is always good :wink:

1 Like

The beta ISO is ready to be tested before GA:

It’s basically the same as alpha but all NS RPM have been rebuilt, I don’t expect any real difference from the previous one.

After install, you should still fix repository link using:

echo 7.5.1804 > /etc/yum/vars/nsrelease
4 Likes

@giacomo i was thinking (reading posts on forum) that maybe before go on with tests of installation from iso it’s better to spend some time in test upgrade from 7.4 to 7.5beta

could you like please write the correct upgrade procedure so i will be sure to not make errors, and maybe some others can help us in testing?

1 Like

This is the procedure:

  1. Get latest upstream updates:

    yum clean all && yum update
    
  2. Update NS repositories:

     yum install http://packages.nethserver.org/nethserver/7.5.1804/base/x86_64/Packages/nethserver-release-7-6.ns7.noarch.rpm
    
  3. Fix NethServer release number

    echo 7.5.1804 > /etc/yum/vars/nsrelease
    
  4. Update everything again

    yum clean all && yum update
    
  5. Everything should already work, but as final step, reboot the machine to load the new kernel:

    reboot
    
2 Likes

tnx!
upgrading from 7.4 to 7.5 i didn’t have Community support and Subscription tab on dashboard… it’s normal behaviour?

and yes in software center still have webvirt :sweat_smile:

upgraded 2 vm one with local AD fileshare and one with firewall, dpi and ntopng, seems ok

i’m not a dpi user so i don’t know if it’s normal (I hope not :grinning: )

installed from iso, fix nsrelease, update
install DPI, reboot
from webui select Status\DPI:

[1] Class 'NethServer\Module\FirewallRules\Index' not found
See the system log for details.

install of Basic Firewall seems to solve

1 Like

Yes, you need to manually install it on updated machines using:

yum update @nethserver-iso

This is documented here: http://docs.nethserver.org/en/latest/release_notes.html#major-changes-on-2018-05

The nethforge repository file has been updated, could you please check if it contains nsrelease variable? Just execute and report the output:

grep nsrelease /etc/yum.repos.d/NethForge.repo

Sadly yes, but it’s cosmetic and shouldn’t normally happen: if you wants to use ndpi, you also need the firewall interface to create the firewall rules.
Do you think we should add a more strict dependency? Just to be clear: when you install nethserver-ndpi the system will automatically install also nethserver-firewall-base-ui.

1 Like

tnx, i did not see it… all ok

# grep nsrelease /etc/yum.repos.d/NethForge.repo
mirrorlist=http://mirrorlist.nethserver.org/$releasever/nethserver?release=$releasever&repo=nethforge&arch=$basearch&nsrelease=$nsrelease
mirrorlist=http://mirrorlist.nethserver.org/$releasever/nethserver?release=$releasever&repo=nethforge-testing&arch=$basearch&nsrelease=$nsrelease

 # cat /etc/yum/vars/nsrelease 
 7.5.1804

almost certainly who install dpi has already installed the firewall-ui, but I see only benefit from a strict dependency in this case

1 Like

Did the update like giacomo described it, everything seems to be ok, so now i just test a bit. Just a short question, which kernel is used by standard? Cause it is installed kernel-3.10.0-693.21.1.el7.x86_64 kernel-3.10.0-862.el7.x86_64 kernel-3.10.0-862.2.3.el7.x86_64, used by boot is 3.10.0-862.2.3.el7.x86_64. Is it right?

1 Like

3.10.0-862.2.3.el7.x86_64 is the right one, thank you fort testing!

1 Like

you guys did again a great job !!! double thumbsup :+1::+1:

2 Likes

I updated my Nethserver infrastructure (firewall, mailserver, VPS and backupbox) and there were no problems so far. A fresh VM install of the beta ISO worked too. Awesome work! :sunglasses:

It should be away after doing yum clean all && yum update again to reload the Nethforge repo.

3 Likes