Testing NethServer 7.5.1804 alpha

I tested the install in a VM and it worked so far. Subscription and Autoupdates are there.
I guess I am too impatient but I could not install nethserver-firewall-base-ui from Software Center or via yum. Other packages are already installable.

Required: nethserver-firewall-base = 3.3.2-1.ns7
Installed: nethserver-firewall-base-3.3.2-1.15.ga382b7d.ns7.noarch (@nethserver-base)

:clap::clap::clap:

same problem here… installation was fine, same problem with firewall but also with other packages like backup or bandwidth. i must disable mirrorlist and enable baseurl in NethServer.repo as it seems not all mirror have 7.5.1804 folder.
after that i can install backup and bandwidth, still problems with firewall
other tests in progress…
for firewall it seems the updated ui package is not available on repo (also if it is)

–> Processing Dependency: nethserver-firewall-base = 3.3.2-1.ns7 for package: nethserver-firewall-base-ui-3.3.2-1.ns7.noarch
—> Package nethserver-firewall-base-ui.noarch 0:3.3.2-1.15.ga382b7d.ns7 will be installed
–> Finished Dependency Resolution
Error: Package: nethserver-firewall-base-ui-3.3.2-1.ns7.noarch (nethserver-updates)
Requires: nethserver-firewall-base = 3.3.2-1.ns7
Installed: nethserver-firewall-base-3.3.2-1.15.ga382b7d.ns7.noarch (@nethserver-base)

forcing installation with

yum install http://mirror.nethserver.org/nethserver/7.5.1804/base/x86_64/Packages/nethserver-firewall-base-ui-3.3.2-1.15.ga382b7d.ns7.noarch.rpm

seems to work

Sorry I cannot reproduce it on my VM (no customizations). What I did:

  • Installed updates from Software Center (yellow banner about 7.5 was present)
  • Installed Basic firewall module

Dependencies were resolved correctly. Did you enable nethserver-testing?

1 Like

With nethserver-testing enabled I get similar error with testing version. I tried it on a fresh VM (no customization). The error occurs after 7.5 install when I wanted to add the firewall-base-ui package.

Required: nethserver-firewall-base = 3.3.2-1.14.g790405e.ns7
Installed: nethserver-firewall-base-3.3.2-1.15.ga382b7d.ns7.noarch (@nethserver-base)

There’s “.noarch” missing in required package but the version of the installed package is higher than the required one.

I can confirm: This way it works.

3 posts were split to a new topic: Local LDAP accounts provider fails to install on 7.5.1804 alpha

Alpha packages are in nethserver-testing repo too… We need to (temporarily) enable it in our testing machines.

1 Like

tnx! i missed it. enabled, i can confirm the problem with nethserver-firewall-ui installation is solved
the strange thing is that i am quite sure i’ve setup nsrelease as you say in first post, but when i checked it was empty :thinking: i’ll try in a new install

edit1: ok retested on a new install.
fixed release number, checked the file (just to be sure :slight_smile: )
enabled testing repo and installed nethserver,

now /etc/yum/vars/nsrelease is still there but is empty
nethserver-testing is still enabled but without rel version yum check against 7.4 repo

edit2: mhhh no there is something else… after setup /etc/yum/vars/nsrelease another time, now is again empty, i’ve just made the first installation wizard

2 Likes

It’s a template, could be overwritten. Echo 7.5.1804 again to it, or prepare a custom-template, like explained here: How to lock to a specific distribution release

2 Likes

nDPI has been reverted to release 1.1.7 because of a major issue.

You can find updated packages in nethserver-testing which should restore a correct behavior.
More info here:

3 Likes

some other install tests:
other packages installed without fail/error:
Backup
Bandwidth monitor
Basic firewall
FTP server
IM-XMPP/Jabber chat server
IPS
MariaDB (MySQL) server
OpenVPN
Print Server
Reverse proxy
SNMP server
Statistics
Web filter
Web proxy
UPS nethserver-nut+collectd-nut
WebTop 5 groupware

Packages with install notes:
Nextcloud (ok but still on version 13.0.1)

Email2: some warnings/error during installation to check (updated after test… retry installation)
pop3 connector 2
pop3 proxy 2
Smtp2

Install of local AD:

systemd-nspawn: Failed to create directory /var/lib/machines/nsdc//sys/fs/selinux: Read-only file system
realmd: Enter Administrator’s password:DNS update failed: NT_STATUS_UNSUCCESSFUL
realmd: DNS Update for ns75f1.framassa.org failed: ERROR_DNS_GSS_ERROR
sssd: tkey query failed: GSSAPI error: Major = Unspecified GSS failure. Minor code may provide more information, Minor = Server not found in Kerberos database.
ns75f1 sssd: tkey query failed: GSSAPI error: Major = Unspecified GSS failure. Minor code may provide more information, Minor = Server not found in Kerberos database.

File Server + Samba audit (with local AD)

May 11 18:36:36 ns75f1 esmith::event[10881]: Can’t open directory /etc/e-smith/events/fstab-update
May 11 18:36:36 ns75f1 esmith::event[10881]: Action: /etc/e-smith/events/nethserver-samba-update/S20nethserver-samba-conf FAILED: 2 [0.314591]
[…]
May 11 18:36:39 ns75f1 esmith::event[10881]: Event: nethserver-samba-update FAILED

Note: there is no fstab-update folder…

if i install ns75 without enable testing i have the folder
/etc/e-smith/events/fstab-update/ (package installed nethserver-base-3.1.5-1.ns7.noarch)

if i use testing repo bedore install the package installed is nethserver-base-3.1.5-1.4.gba58ecc.ns7.noarch.rpm and there is no the requeste folder… i’ll check on github…

3 Likes

In Nethserver is available the update to 7.5. It is stable or not?

We are here in the 7.5 alpha testing thread so it’s not stable. The stable 7.5 will be announced…

2 Likes

Thank you for your detailed test @dz00te, it’s a great contribution towards a stable release! I hope to see more people involved in the @quality_team, expecially during transition phases like this!

3 Likes

I have update from Software Center, but in the Dashboard the version is 7.4. I have to reboot the server?

2 Likes

If want to contribute with alpha 7.5 tests run steps 3 and 4 of the initial post. Then run

 yum update

Be prepared to reinstall from scratch or restore a backup/snapshot of your server.

Reboot runs the new kernel but doesn’t change the release number: you need to update from 7.5.1804/testing repo for that.

yes probably is the removed fstab management in nethserver-base

maybe nethserver-samba still use it ?

It’s possible: Samba requires Posix ACLs thus it changes the ext4 options. As ns7 has xfs it is not required any more.

1 Like

Alpha 1 ISO is ready to be tested: http://www.nethserver.org/iso/nethserver-7.5.1804-alpha1-x86_64.iso

We also fixed:

3 Likes

tnx! downloading…

tested install on local AD + File Server and samba audit. no probs
i have some failure in log, i’ll check them better later

sssd: tkey query failed: GSSAPI error: Major = Unspecified GSS failure. Minor code may provide more information, Minor = Server not found in Kerberos database.

2 Likes