Strange behaviour of samba: users, groups and ACL changed

NethServer Version: 7.5
Module: samba, AD

OK, this is a little wired to desribe, but I try my best:
I set up an AD with different groups and users. Example:
group: parents … users dad, mum
group: family … users dad, mum, kid1, kid2
group: multimedia … users dad, mum, sonos

Also shares for different groups are available, e.g.
share “music” owner group is “multimedia”
share “tax” owner group is parents.

Most shares are linked permanently on Windows 7 Ultimate desktops to individual uses, e.g. dad has the following shares:
T:\ is linked to \myserver\tax
M:\ is linked to \myserver\music
and much more

All worked fine, while I do not use all shares every day. Today I noticed the following: I am logged in as “dad” and I had to use a shared directory which I do not use on a daly base. Consequently it was not linked. In my case call it \myserver\video.

When browsing to \myserver\ I found that I was able to see the share “sonos@myserver.tld” … moreover was able to open the share … So I could get into a share of another user (as which I am NOT logged in)

Moreover: I was not able open shares I use regularly, e.g. T:\ which is linked to \myserver\tax. Other shares were forbidden to.

Can someone help? This is not older than 3 maybe 4 days …

Are there saved credentials in credential manager? You may try to remove them…


1 Like

Yes, THX, that worked. But:

I am quite confused as am used to to different behaviour: How can it be that a secondary / subsequent mount of single directory influcences the complete AD logon behaviour? I mean: OK, if I get some additional share access, but in addition I get logged out form shares the logged in used does have access regularly?