[SOLVED] Some services won't install


(Jonathan Dumont) #1

When I try to install the Email module with or without option I receive this :frowning: at 4%
like it said I tried to report into your redmine but didn’t understand how to post a new issue.
if I try to install another module like httpd it’s working without error.

Task completed with errors

Applying changes #2 (exit status 1)
[YumRPMCheckError] [u’ERROR with rpm_check_debug vs depsolve:’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-ExtUtils-ParseXS-1:2.2003.0-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Archive-Tar-0:1.58-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-devel-4:5.10.1-136.el6_6.1.x86_64’, ‘glibc-common = 2.12-1.149.el6_6.9 is needed by glibc-2.12-1.149.el6_6.9.i686’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Package-Constants-1:0.02-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Test-Harness-0:3.17-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-ExtUtils-MakeMaker-0:6.55-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Digest-SHA-1:5.47-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-IO-Zlib-1:1.09-136.el6_6.1.x86_64’, u’Please report this error at http://dev.nethserver.org/projects/nethserver’]


Any Success installation with CentOS 6.7?
(Jonathan Dumont) #2

I have the same issue with snort and VPN
but was able to install XMPP, MySQL and NTOP

Task completed with errors

Applying changes #2 (exit status 1)
[YumRPMCheckError] [u’ERROR with rpm_check_debug vs depsolve:’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Package-Constants-1:0.02-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Archive-Tar-0:1.58-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Digest-SHA-1:5.47-136.el6_6.1.x86_64’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-IO-Zlib-1:1.09-136.el6_6.1.x86_64’, u’Please report this error at http://dev.nethserver.org/projects/nethserver’]


Task completed with errors

Applying changes #2 (exit status 1)
[YumRPMCheckError] [u’ERROR with rpm_check_debug vs depsolve:’, ‘perl = 4:5.10.1-136.el6_6.1 is needed by perl-Digest-SHA-1:5.47-136.el6_6.1.x86_64’, u’Please report this error at http://dev.nethserver.org/projects/nethserver’]


(Giacomo Sanchietti) #4

Just execute these commands from command line and paste the output:

  • yum repolist
  • yum install @nethserver-mail-server

(Jonathan Dumont) #5

Thank for your help giacomo

[root@x42 ~]# yum repolist
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Loading mirror speeds from cached hostfile

  • nethserver-base: mirror.nethserver.org
  • nethserver-updates: mirror.nethserver.org
    repo id repo name status
    centos-base CentOS-6 Base 6,518
    centos-updates CentOS-6 Updates 1,370
    nethserver-base NethServer 6.6 base 327
    nethserver-updates NethServer 6.6 updates 273
    repolist: 8,488

[root@x42 ~]# yum install @nethserver-mail-server
Loaded plugins: changelog, fastestmirror, nethserver_events, presto
Setting up Install Process
Loading mirror speeds from cached hostfile


(Jonathan Dumont) #6

if I try yum install nethserver-mail-server

Error: Package: glibc-2.12-1.149.el6_6.9.i686 (centos-updates)
Requires: glibc-common = 2.12-1.149.el6_6.9
Installed: glibc-common-2.12-1.166.el6_7.1.x86_64 (@updates)
Error: Package: perl-Test-Harness-3.17-136.el6_6.1.x86_64 (centos-updates)
Requires: perl = 4:5.10.1-136.el6_6.1
Installed: 4:perl-5.10.1-141.el6.x86_64 (@base)

etc…


(Artem Fedai) #7

it is very interest :slight_smile:


(Jonathan Dumont) #8

but it’s a bare fresh CentOS 6.6 installed
should I remove all of those requirement ?


(Artem Fedai) #9

cat /etc/redhat-release


(Jonathan Dumont) #10

[root@x42 ~]# cat /etc/redhat-release
CentOS release 6.6 (Final)


(Artem Fedai) #11

wow, so remove Glibc and so on and install
yum install -y --disablerepo=centos-updates glibc glibc-common


(Jonathan Dumont) #12

[root@x42 ~]# yum install -y --disablerepo=centos-updates glibc glibc-common
Loaded plugins: fastestmirror, presto

Error getting repository data for centos-updates, repository not found

this is my kernel in case :wink:
[root@x42 ~]# uname -a
Linux x42 2.6.32-504.1.3.el6.x86_64 #1 SMP Tue Nov 11 17:57:25 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


(Jonathan Dumont) #13

I found the trouble, it’s the image of CentOS 6.6 furnish by Exoscale, they claim it’s a bare fresh image but in fact they use EPEL source to build their image. :frowning:
Thanks for your help, i’ll try to see with them!