[SOLVED] Backup-data mystery on dashboard

dashboard
backup
v7

(RoWiHei) #1

NethServer Version: 7
Module: nethserver-backup

Last backup-log:
_Backup: backup-data Backup started at 2019-02-04 12:30:02 Pre backup scripts status: SUCCESS --------------[ Backup Statistics ]-------------- StartTime 1549279844.97 (Mon Feb 4 12:30:44 2019) EndTime 1549279857.69 (Mon Feb 4 12:30:57 2019) ElapsedTime 12.72 (12.72 seconds) SourceFiles 16082 SourceFileSize 10044684035 (9.35 GB) NewFiles 55 NewFileSize 15188 (14.8 KB) DeletedFiles 3 ChangedFiles 133 ChangedFileSize 15771162 (15.0 MB) ChangedDeltaSize 0 (0 bytes) DeltaEntries 191 RawDeltaSize 1466123 (1.40 MB) TotalDestinationSizeChange 329084 (321 KB) Errors 0 ------------------------------------------------- Action 'backup-data-duplicity backup-data': SUCCESS Post backup scripts status: SUCCESS Backup status: SUCCESS Backup ended at 2019-02-04 12:30:59 Time elapsed: 0 hours, 0 minutes, 57 seconds Disk Usage: Size Used Available Use% 2.73 TB 27.70 GB 2.57 TB 0.99%_

But on dashboard the backup is ready, BEFORE it’s starting …? think using UTC ?
2019-02-04-backup-data


(Marc) #2

Maybe related to php timezone:


or an old bug reocurring:


(Federico Ballarini) #3

Hi @rowihei

I think it’s a problem with php timezone.

Check with
ll /var/spool/backup/status-backup-data
if the time of end-backup is correct (i think it will be 12:30)

Now, do the command
config getprop php DateTimezone
if you get UTC it’s a problem with php timezone.

Set the new php timezone with
config setprop php DateTimezone "Europe/Rome"
signal-event nethserver-ntp-save
expand-template /etc/php.d/nethserver.ini
systemctl reload httpd
systemctl restart httpd-admin

Change Europe/Rome with your timezone Europe/…

Maybe someone of dev team can check why in the installation process php timezone isn’t set correctly.


(RoWiHei) #4

Hallo, federico.ballarini,
that’s it - now the info on dashboard looks OK


(Federico Ballarini) #5

Could you mark please as solution? Thank you.