Sogo white page

I have a problem some time with Sogo, after login only white page is showed?

failed to acquire channel for URL: mysql://sogo:PysFxg5MZxWE_3KR@localhost/sogo/sogo_user_profile

never saw, maybe a mysql issue, does mysql is under load when the blank page is present for example, this could be interesting to know

I don’t know, i reinstalled now and it works, i mean nethserver 7

Not really scientist, but sometime it works, still probably a mysql issue, maybe mysql was done, or with a timeout, who knows

I think also that mysql was problem.

1 Like

So, today again, new installation, and after update , maybe German language?
ERROR] <0x0x562709839bd0[SOGoSQLUserProfile]> failed to acquire channel for URL: mysql://sogo:_2tiIWbgHd2RKXgp@localhost/sogo/sogo_user_profile

I can log in, but than white page.

I think i found what the problem was, i uninstalled nethserver-mail-quarantine and nethserver-mail-disclaimer, and it works now.

None use mysql, really low chances you found the root of the issue

well it works without it.I’ll install them again and try

i installed again, white page after reboot.

I am uninstalling only disclaimer now.

Without disclaimer and quarantaine it works, with those 2 no.I tried now with or without them.I have installed in esxi 7.6 Nethserver 7.

Fun but when you remove a rpm, you expand all the templates and restart all services, hence you restart mysql

When you have the blank page, can you connect to mysql, do you have other apps that use mysql?

Maybe we could try to drop the sogo database in mysql, then if you reinstall nethserver-sogo it will be created again

You will lose calendars and contacts

Ok THX, i will try

check in mysql log when occurs the blank page

Ok, i am installing it new.
It was happening also with new installation.

probably because the db is corrupted and not removed manually

I reinstalled again everything, rebootet two times, and it works now.I don’t know really what is it, but, if this occures again, i’ll send here mariadb log and try what you wrote before.
Thank you a lot.

1 Like

Or can it be that i connect first with outlook activesync?And this time i log in at first with sogo.

And again,

190519 17:33:05 mysqld_safe mysqld from pid file /var/run/mariadb/ ended 
190519 19:33:02 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql 
190519 19:33:06 [Note] /usr/libexec/mysqld (mysqld 5.5.60-MariaDB) starting as process 6215 ... 
190519 19:33:08 InnoDB: The InnoDB memory heap is disabled 
190519 19:33:08 InnoDB: Mutexes and rw_locks use GCC atomic builtins 
190519 19:33:08 InnoDB: Compressed tables use zlib 1.2.7 
190519 19:33:08 InnoDB: Using Linux native AIO 
190519 19:33:09 InnoDB: Initializing buffer pool, size = 128.0M 
190519 19:33:09 InnoDB: Completed initialization of buffer pool 
190519 19:33:09 InnoDB: highest supported file format is Barracuda. 
190519 19:33:13 InnoDB: Waiting for the background threads to start 
190519 19:33:14 Percona XtraDB ( 5.5.59-MariaDB-38.11 started; log sequence number 3359925 
190519 19:33:14 [Note] Plugin 'FEEDBACK' is disabled. 
190519 19:33:15 [Note] Server socket created on IP: ''. 
190519 19:33:16 [Note] Event Scheduler: Loaded 0 events 
190519 19:33:16 [Note] /usr/libexec/mysqld: ready for connections. Version: '5.5.60-MariaDB' socket: '/var/lib/mysql/mysql.sock' port: 3306 MariaDB Server