SOGo on Nethserver 7B2

NethServer Version: 7 Beta 2
Module: SOGo

Hi all, I have installed Nethserver 7 Beta 2, to use it mainly as Mail and Collaboration Server. I have installed LDAP, Mail components and SOGo.

My problem is that when I try to connect to I have a 404 error, and in effect I cannot see anything under the html directory.

I have probably forgotten something, but what ? Can you help me ?



Did you install sogo too? :slight_smile:

Yes I did it :slight_smile:

Hi Andrea,
Did you try with https:// ?

yes, I tried both, but in both cases I had a 404



I can add that if I connect via ssh, I can see SOGo processes running. But /var/www/html dir is empty.


Try with IP instead FQDN to see if is a problem with DNS.

it is not a DNS problem, because if I go to I can see the NethServer welcome page and on the server manager.



What about MX registration?
The email server is mail.fqdn/sogo, or fqdn/sogo?
(sorry, I type from my phone and is not so comfortable)

MX registration is still pointing to the old server. I’m just testing Nethserver and I would like to understand how it works, in particular SOGo and integration with Mobile Phones.

As of now, I’m just trying to connect to the WebInterface.

Thank you for your support.


1 Like

You’re welcome!
Enjoy NS.
You will love it!

Hi Andrea (and @GG_jr),

I chip in for some suggestions, unfortunately i ditched the VM with sogo running just a few hours ago…

So you know your way around the liunx file system, but first i suggest to restart the webserver:
in the UI goto services look for httpd (HTTP) and restart it -or-
from the terminal
systemctl restart httpd
and as we ar at this resart sogo as well: sogod in the UI -or-
systemctl restart sogod

SOGo is not located in /var/www/html but elsewhere.

1 Like

Thank you Mark. I have restarted both the httpd server and the sogod server. But still I cannot see the webinterface :frowning:

Do I need to have any other component installed to use SOGo ? samba4 or something else ?

Thanks again


No, - as always :joy:- it should work.

You can confirm sogod and httpd are running?
Could it be you installed sogo before Ldap?

Yes, I confirm that both the server are running, and also that I installed SOGo before LDAP. Is it an error ?


Yeh i think that could be a problem.

We can try to reconfigure SOGo; IIRC:

from the terminal
signal-event nethserver-sogo-update

Tried, but still 404. Maybe I can unistall and reinstall the package ?


Before reinstalling could you have a look at


there should be something like this in there:

  /* 45 ldap authentication */
        id = groups;
       type = ldap;

Yes, there are these lines.

But I’m not sure they are fine. I installed samba4, then SOGo, but after that I removed samba and installed LDAP, maybe this created a problem.


Sorry have to leave the answer to this to real experts on the this subject :open_mouth: