SOGo on Nethserver 7B2

Thanks Mark, I appreciated your help.

Andrea

Sorry your problem still exists, I think removing Samba and Installing Ldap could be the cause of it;
I just not sure.

My personal workflow installing NS is always:
install from iso > set fixed IP > update > reboot > choose and install account provider > install other modules

well, you’d better start from a clean install and try again

Hi Andrea,
you installed Smba AD first, removed it and installed then LDAP as accountprovider. This is not ment to be done, install NSDC or LDAP is a one-way-operation, not reversible. Only one of them, never together. Sorry, I know it is not documented in softwarecenter. I think that has to be figure out for stable release, what do you think @davidep ? Please bear in mind that NS7 is still beta. I’m afraid you have to start from begining. If you install LDAP as accountprivider, you can login with every user you create in the user and group panel to SOGo-webinterface. But first you have to create a user called “admin”. This user is recongized by SOGo as administrator for SOGo. AFAIK only when SOGo has this admin user you can login with other users.
refer to this disccussion: How i can login to SOGO NethServer v7B2

Good luck. Please let me know if it had worked.

To remove Samba AD, please follow the procedure as described here:
http://docs.nethserver.org/projects/nethserver-devel/en/v7b/nethserver-dc.html#factory-reset

Before starting removing and reinstalling things, you should try to figure out the problem :slight_smile:

You have many commands to do it:

  1. Just figure out if sogo is really running

    systemctl status sogod
    
  2. Check if sogo is listening on network port. If so, contact sogo using curl

    netstat -lanp | grep sogo f
    curl http://localhost/20000

  3. Check for errors in main log:

    less /var/log/messages

  4. Check for errors in sogo logo

    less /var/log/sogod.log

  5. If Sogo is running, start digging into http error logs

Happy hacking :wink:

Hi all, sorry to have not answered, but it seems that as a new user I cannot participate in threads with more than 21 messages on the same day :slight_smile:

Anyway, I have reinstalled from scratch, now I will install LDAP, Mailserver and then SOGo. Is it the right path in your opinion ?

Thanks to all of you.

Andrea

2 Likes

updating a new install is always a good idea:
goto: software center > updates (if it is a long list including a kernel i recommend to reboot)

Yes it is!

1 Like

after the installation I run yum -y update. Now I will reboot and install the applications

Thanks Mark.

Andrea

1 Like

Nethserver works hard to avoid the command prompt, but that’s the way i do it :slight_smile:

Have fun!

Done !!!

It works :slight_smile:

Now I would like to use ActiveSync, is it part of the installation or do I need to install something more ?

Thank you all for your support.

Andrea

1 Like

Nice!

No further installations are required. On android it cant be a bit flunky, an still looking in to that, its a bit of upstream problem at SOGo. There for I use Cal/CardDAV.

1 Like

You’re ready to help too
Wow 31 replies from 5 different guys. No bad :slight_smile:
I love this people :heart: what do you think @andreadb?

Thank you guys, I have really appreciated your help.

I’ll do my best to support the community :+1:

Andrea

2 Likes

HI @andreadb :slight_smile:
You are able to run activesync? You need more information?

Hi @enzoturri

Yes, I have been able to run it on the Beta2, following @mark_nl suggestions. Still have not moved on RC1.

Ciao

Andrea

2 Likes

Thanks @andreadb for the reply.

Great!!
If you believe that the cause of the problem has been identified, you can mark “solution” in the decisive response. This helps the reader to identify the questions that require support from those resolved.

1 Like