SOGO not working

config show sogod

What is the output?

sogod=service
ActiveSync=enabled
AdminUsers=admin
BackupTime=30 0
Certificate=
CustomEmailField=userPrincipalName
Dav=enabled
DraftsFolder=Drafts
MailAuxiliaryUserAccountsEnabled=YES
Notifications=Appointment,EMail
SOGoInternalSyncInterval=30
SOGoMaximumPingInterval=3540
SOGoMaximumSyncInterval=3540
SOGoMaximumSyncResponseSize=2048
SOGoMaximumSyncWindowSize=100
SentFolder=Sent
SessionDuration=1440
SxVMemLimit=1024
TrashFolder=Trash
VirtualHost=
WOWatchDogRequestTimeout=60
WOWorkersCount=10
status=enabled

I made some modifications, like increasing the SxVMemLimit, but didn’t work…

config setprop sogod WOWorkersCount 20
signal-event nethserver-sogo-update

we could try to increase the number of workers

I did that put 150 worker, same result…
And I only have 2 Users, so 10 should be more than enough…

check with another webmail, sogo use dovecot with imap, maybe the problem is relative to this and not related to SOGo

I can read my mails with POP3 and SMTP for sending, that works.
I tried to install webtop, but it didn’t work and i don’t want to destroy my installation.

I think it must be the connection between webserver and sogo.

I’ve tried to check the log files but can’t find any information or errors…

why ?

explain please, you can test with roundcubemail else

pop != imap

do you have some clues in maillog

IMAP works…

I’ve installed webtop, but the webpage was not reachable. Also I want to keep Outlook and Android as Mail clients and from what I read webtop doesn’t fully support it. I need contacts and calendar…

Sogo works great (if it would work again)

well not sure it is sogo related

No other ideas???

what is the output of

systemctl status sogod

could you explain better what are the issue you have, with a screenshot of the error you see for login

[root@diener ~]# systemctl status sogod
● sogod.service - SOGo is a groupware server
Loaded: loaded (/usr/lib/systemd/system/sogod.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2020-01-15 21:33:16 CET; 4 days ago
Main PID: 6785 (sogod)
CGroup: /system.slice/sogod.service
├─ 3591 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6785 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6789 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6792 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6793 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6794 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6795 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6797 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─ 6798 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
├─16315 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…
└─24071 /usr/sbin/sogod -WOWorkersCount 10 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log…

Jan 15 21:33:16 diener.mds4u.local systemd[1]: Starting SOGo is a groupware server…
Jan 15 21:33:16 diener.mds4u.local systemd[1]: Started SOGo is a groupware server.

unhandled error reply, try again.

I do get Mails via Activesync on outlook, but very slow, takes half an hour for a mail to show up in outlook. On android I get an error too.
I still think it’s a timeout problem…

1 Like

probably but due to another cause I bet

SOGo relies on

  • dovecot to retrieve email and browse them (not sure it is related :-?)
  • mysql to store rendez-vous, contacts, and users settings (could be the problem)
  • smtp to send email (not sure it is our guilty)
  • ldap to login (yes it could be a cause)
  • activesync to allow sync on remote device (I do not know)

something is wrong in this association

2 posts were split to a new topic: SOGo_4.3 needs to be build

A new version of SOGo is available, you should test it, if it doesn’t fix you issue, you should ask a support by SSH to fix your issue.

yum update sogo\* sope\* --enablerepo=nethforge-testing -y

Didn’t work, same problem.
I still think it’s not SOGo but the web-server, proxy, ip config or such…
Who wants to get on my server and look for the error?

2 posts were split to a new topic: Restored NSDC - Account provider generic error: SSSD exit code 1