SOGo and AD brainstorming

NethServer Version: 7.3.1611
Module: nethserver-sogo

Ok, I’m testing a solution for a customer
AD domain realm is something like domain.local
public domain is something like mycompany.tld

NS is successfully joined to AD domain, its only domain is mycompany.tld, I see all users and groups… so far, so good.

If I use userPrincipalName AD attribute (user@domain.local), once logged I see that this is my email address… I’d edit all accounts properties to change it to user@mycompany.tld…
in sogo’s documentation I read, regarding MailFieldNames:

An array of fields that returns the user’s email addresses (defaults to mail when unset). Note that SOGo will always automatically strip the protocol value from the attribute if the attribute name is proxyAddresses.

If I create a custom fragment to unset the MailFieldNames value or to set it to “mail”, once logged in webmail I see I’m using the correct email address… but…

but once logged I see in /var/lib/nethserver/vmail a dir named user@domain.local; if I send an email to this user on its real email address (either from an external account or from an internal one) a new dir named user@mycompany.tld is created and I can’t see its content from my webmail or my email client.

since my customer has only one domain I’d like to know how to setup my NS to solve my issue or an howto to configure it in such a situation


Which field have you changed?



I created a custom fragment 45user_source and in AD section I edited the MailFiledNames from

MailFiledNames = ("userPrincipalName");


MailFieldNames = ("mail","userPrincipalName");

Hi Stefano,
could you try to create a custom template with:

SOGoMailDomain = “mycompany.tld”

I can’t try at the moment, I only have a sogo at a production system.

I already have SOGoMailDomain with that value, without any need of custom fragment

@dev_team Does anybody of you have an idea?

I solved creating a custom fragment and setting:

IMAPLoginFieldName = mail;

instead of

IMAPLoginFieldName = userPrincipalName;

BTW, now I have a new issue (maybe 2):

if I compose a new mail and search for an internal user, both domain.local and mycompany.tld addresses are shown (and I don’t like it)
moreover, searching for an address, I get the workstations (joined to domain) names, and this is clearly a bug

hope @stephdl will jump in, I know that nethserver-sogo is a package from him

Thank you in any case for your help


next step is to add the openchange packages to add MAPI layer…
I see that some packages are available here:

unfortunately all openchange stuff is available (from Inverse) only on debian/ubuntu distro

anyone interested in?

I’m testing it again because with a full updated ns, when I use SOGo, the email address was not the dummy samba one.

I will back here


email in sogo was

1 Like

can you reproduce it with a full updated NS7.9… I just tried with another vm

email domain name :

I see the email in the upper left sogo page, and not toto@AD.PLOP.ORG

It’s interesting, but last times I tested it with zentyal (1 year ago) it was very bugy.

1 Like

thank you for your feedback
I see that altlinux packages are based on last release (20th july 2017)

BTW… I’m asked to find a real alternative to exchange… unfortunately sogo can’t be considered one, 'cause openchange is unsupported on centos and TB integration seems broken with latest releases of TB, lightning and sogo connector/integrator packages…
webmail is not an option, even if I have some customers that are using it

I’ve tested it with thunderbird 52.4.0 SOGo Connector 31.0.3 and lightning 5.4.4, that works for me.
What are your problems?

with connector and integrator 31.0.5 it doesn’t work… I saw some errors in TB’s debug console but now I can’t post them

Ok, I tried with version 31.0.5 of SOGo Connector now, it works without problems, I didn’t tried with Integrator, but if you post errors later perhaps we can find the issue and I can compare the output with and without integrator.

1 Like

I’m using NS 7.3.1611 with nethserver-sogo- package

I confirm that having this setup:

NetBIOS domain name: DOMINIO
LDAP server:
LDAP server name: DC-W2008.dominio.local
Bind Path: dc=DOMINIO,dc=LOCAL

servicePrincipalName: imap/
servicePrincipalName: imap/mail
servicePrincipalName: pop/
servicePrincipalName: pop/mail
servicePrincipalName: smtp/
servicePrincipalName: smtp/mail
servicePrincipalName: HOST/
servicePrincipalName: HOST/MAIL

creating an user with or without an explicit email value in mail filed on AD will lead to such a situation

Using my fragment, creating an user without an explicit email address I see:

ok, clean install of TB 52.4.0 32 bit on a new w10 pro joined to the domain, installed sogo-connector-31.0.5.xpi, created a new account

in the debugger console I read:

NS_ERROR_MALFORMED_URI: Component returned failure code: 0x804b000a
(NS_ERROR_MALFORMED_URI) [nsIIOService2.newURI] sogoWebDAV.js:157
_makeURI chrome://inverse-library/content/sogoWebDAV.js:157:16

sorry for the bad formatting, can’t make a simple copy and paste

And it simply doesn’t work


now it works… and I didn’t touch anything :expressionless:
will investigate
Thank you

1 Like

I recall something similar to your issue, we talked about sometime ago with davidep. I tought the issue was solved by an update because i tested last night with a fresh vm

Start the vm
Full update
Install nethserver-dc
Install nethserver-sogo

Like i said i cannot reproduce your issue but we might do some changes like you introduced

Do others can test and see if the domain name in sogo is a dummy or good one ?