SOGo Active Sync


NethServer Version: 7.3.1611
Module: SOGo

I am trialing Nethserver with a view to banishing Google from my life. I have SOGo installed and working fine apart from Active-Sync.
The server is setup with SSL and the I have no problem logging in to the web interface. However when I try to connect my Android phone to ActiveSync I get ‘Unable to set up account - Unable to connect to server’.
I am using for my username.

I am running the final release of Neth v7 and I a have just updated to the latest SOGo patches.

Does Active sync require an AD backend? I am just using Local LDAP.

Here’s a snip from the HTTP-SSL logs:

[20/Feb/2017:01:37:17 +0000] “GET / HTTP/1.1” 403 4119
[20/Feb/2017:01:37:17 +0000] “GET /favicon.ico HTTP/1.1” 404 209 [20/Feb/2017:01:37:17 +0000] “OPTIONS /Microsoft-Server-ActiveSync?Cmd=OPTIONS& HTTP/1.1” 200 - [20/Feb/2017:01:37:18 +0000] “POST /Microsoft-Server-ActiveSync?Cmd=FolderSync& HTTP/1.1” 449 - [20/Feb/2017:01:37:18 +0000] “POST /Microsoft-Server-ActiveSync?Cmd=Provision& HTTP/1.1” 401 1034

Many thanks

Something interesting in sogo logs ?

1 Like

No, it should work regardless of the backend.

Afraid there’s nothing in the sogo logs only the service startup messages.

@giacomo the login part for activesync is ‘’ or only ‘username’

I don’t remember, but it should be the same of web interface.

1 Like

ok, on the web interface, the login part is just ‘username’, @GOB can you try

Yes, I’ve tried every permutation of name and domain/host name. Still no

@hucky @frx44 @flatspin @asl do you have clues to help this man…

Sorry I don’t use Active Sync at the moment, so I can’t give a hint. :cry:
If I have some time, I will play with it. :pray:

1 Like

hmm, no idea at the moment, i am using it with AD and everything works well so far…

SSL on Android needs a valid certificate sometimes (depends of Android version). You could use Let’s Encrypt certificate or you could install the self signed certificate manually as trusted certificate on your android device. First option would be easier, as you do not need to touch your android device…
Give it a try!
I’m using it here and it works.


I already have a let’s encrypt cert installed and that works fine in all of
my browsers including on android.

which version of sogo and nethserver-sogo do you use

rpm -qa sogo nethserver-sogo

as a workaround I use my ‘degooglisation’ by imap/caldav/carddav with sogo. I have a real problem with all microsoft formats.


Thanks @stephdl

Thanks all for chipping in thus far.
I have managed to get the IMAP/Caldav etc working externally but ideally I would rather not open up that to the internet, purely to reduce the attach surface. I would prefer to just have 443 open with SSL.
Yes, I know I could set up a VPN to gain access to them but that wouldn’t go down too well with the family.


Also… don’t know if this impacts anything… I am using a Samsung Galaxy S6 with the standard Samsung email client.
This client is also connecting to my exchange servers at work without problem.
I did try the Microsoft Active Sync tester website and that threw an error saying something about anonymous access was enabled, which is a bad thing.

slightly OT, but usually default mail client on android are c**p :slight_smile:


Maybe @kisaacs can give a hint. I think I can remeber that he uses active sync a lot with different devices.