Sogo 2.2.15 is available to test

testing
sogo

(Alessio Fattorini) #1

Continuing the discussion from Today I’m working on NethServer:

Hey folks!
are you curious to test last SOGo version 2.2.16 with ActiveSync support? Now you can.
Just 2 advices:

  • don’t test it on production environment
  • please report your tests , whether successful or not, replying this topic.

This is the command to upgrade

yum --enablerepo=nethserver-testing update sogo sogo-tool sope49-appserver sope49-cards sope49-core sope49-gdl1 sope49-ldap sope49-mime sope49-sbjson sope49-xml nethserver-sogo-thunderbird sogo-frontends nethserver-sogo

Answering to @sitz

  • yes you can upgrade 2.1.1b version
  • no tuning required
  • new account with https link is ok

Feel free to ask whatever you want


Openchange and Outlook MAPI Exchange compatibility
Viable Windows SBS Replacement?
Community Acknowledgments
(Roberto Sitzia) #2
sope49-gdl1 sope49-gdl1 sope49-gdl1 

Confirm three times @alefattorini?


(Alessio Fattorini) #3

Thanks @sitz fixed. Have a good week-end


(Stefano Fancello) #4

You miss nethserver-sogo, that took with it sogo-activesync and libwbxml… ActiveSync won’t work!

That’s the command:

yum --enablerepo=nethserver-testing update sogo sogo-tool sope49-appserver sope49-cards sope49-core sope49-gdl1 sope49-ldap sope49-mime sope49-sbjson sope49-xml nethserver-sogo-thunderbird sogo-frontends nethserver-sogo

And the version of sogo* packages that we have in our repositories is 2.2.15-1, if someone want to try 2.2.16-1, let us know if everything keeps working as expected.


(Alessio Fattorini) #5

Thanks mate! Just updated the command :wink:


(Stéphane de Labrusse) #6

Just for my Information, do you patch the sogo software, or do you simply release a given version of sogo…In other hand, can we be bleeding edge and upgrade directly from sogo repository ???


(Alessio Fattorini) #7

No patch! Always upstream complaint.
Sure I like bleeding edge :wink: go ahead!
Let me know if it works!


(Stefano Fancello) #8

You can go bleeding edge, but better testing before release it to all NS users


(Giuseppe Trianti) #9

hi Alessol. How can try active sync with my mobile phone (i have lollipol) ?


(Alessio Fattorini) #10

Sure, you have to configure an exchange account


(Giuseppe Trianti) #11

Thanks, i checked in my phone but i didn’t find it.

Should i download some app too ?

Sorry but I’m pretty new :smiley:


(Alessio Fattorini) #12

Preferences -> Account -> New Account -> Exchange
Happy test! :smile:


(Giuseppe Trianti) #13

I already tried but my phone doesn’t included exchenge account (i don’t know why). I downloaded activesync app and it works well.
Ciao


(Alessio Fattorini) #15

Has Anyone tested it? Any hint? :wink:


(Roberto Sitzia) #16

Yes @alefattorini I have spent all this afternoon preparing the environment but above all trying to connect my Outlook 2010 with SOGo 2.2.15 with no results.
After updating my 2.1.1b SOGo installation I followed instructions here http://www.sogo.nu/files/docs/SOGo%20Native%20Microsoft%20Outlook%20Configuration.pdf

Outlook ask me for credentials but nothing more.

Can anyone give me some help? :frowning:
Can anyone tell me steps to troubleshooting this behavior, which logs services ports etc.?
Thanks.


(Stefano Fancello) #17

@sitz make sure (rpm -q) that your nethserver-sogo version is >= 1.4.1-1.15.gcba4b05
If you have NS 6.6, 1.5.0-1 is available since yesterday.
open in your browser https://NS_IP/Microsoft-Server-ActiveSync you should see this message

An error occurred during object publishing
reason for HTTP error unknown

then try to configure an organization account on your Android device calendar. If it works, it’s an Outlook configuration issue and I’m not able to help you anymore :slight_smile:
If on your browser you have this error:

Not Found
The requested URL /Microsoft-Server-ActiveSync was not found on this server.

new httpd configuration is not properly deployed…and it means that I’ve done something wrong :grin:


(Roberto Sitzia) #18

Hi @Stll0 my test environment is built on NethServer 6.5 with this version of SOGo

 [root@v-nethserver ~]# rpm -q nethserver-sogo
 nethserver-sogo-1.4.1-1.16.gd58c5e7.ns6.noarch

With my Android device ActiveSync synchronization works fine and I’m agree with you that it could be an Outlook issue but I didnt’ask some help for Outlook but how to troubleshooting correctly this kind of situations.

Before troubleshooting, do you suggest me to undate to NS 6.6 and latest SOGo release?
Thank you for your help.


(Stefano Fancello) #19

I’ve asked about Android to figure out if it could be server or client issue. If it was server, I could dive into trobleshooting with you, but I’m completely ignorant on outlook…

[quote=“sitz, post:18, topic:203”]Before troubleshooting, do you suggest me to undate to NS 6.6 and latest SOGo release?Thank you for your help.
[/quote]
It’s the same for your purpose.
But focus on client side. I’d bet on some self-signed certificate related issue.


(Alessio Fattorini) #20

Keep a look to this http://www.sogo.nu/files/docs/SOGo%20Installation%20Guide.pdf especially the ActiveSync tuning part

Some parameters are db nethserver props yet, so it’s easy to manage them
http://dev.nethserver.org/issues/3063#note-2


(Tommaso Cavallini) #21

Hi Everyone,
the issue is related to the outlook version, outlook 2010 did not work with active sync, only Outlook 2013 does.
To use outlook 2010 openchange is needed, and I understood that in NethServer is not configured.
Let me know if I’m wrong, I’m trying to connect outlook 2010 with no results too…