Shell policy Override the shell of users stops all logins from working except root


When I enable this feature to gain access to the user-settings page, all logins are stopped. This includes mail server, smb etc. The user is given permission denied errors and email clients can’t log in on imap etc.

I can log in as root on cockpit and disable this feature and all returns to normal. But I really want to give my users access to the user-settings page.

Please activate it, try to login with a user and post the relevant fragment of messages.log. Also you may have a look at mail and smb log.



Sorry for the long delay. I had to do the tests when no users were on, which meant an early start for me today.

I shut down all the virtual machines, and then rebooted the server. Now the logins are working, but on accessing the setting page I get a blank web page and on checking webpage with inspect get

cockpit.min.js:347 WebSocket connection to ‘wss://’ failed:
t @ cockpit.min.js:347
cockpit.min.js:502 transport closed, dropped message:

Which browser do you use? There are some problems with safari.

I used Google chrome for testing…and have just tried mobile browser, and AdBlock browser, same blank page.

Can you test firefox please. If it is the same problem, press F12 and post the output of the console here.

It came right after midnight. Must have been Gremlins…F12 post is as above.

Looked like the service was rejecting ws connection.

1 Like