Shared Mailbox / SoGo is denied

mail
v7
sogo

(Dennis Lloyd) #1

NethServer release 7.4.1708 (Final)
email / Shared Mailbox

I am having an issue trying to share a mailbox to an LDAP group.
Configuring Management > Email Addresses > Shared mailboxes

I created a new Shared mailbox called FAX
Owner Groups is set to a group I have membership in
No extra ACL set under special access.

client in Sogo can see the shared box, but permission is denied (sogo.log)
Dec 22 10:06:18 sogod [5292]: [ERROR] <0x0x56211ad68790[NGImap4Connection]> could not select URL: imap://dlloyd%40domain.com@localhost/Public/: {RawResponse = "{ResponseResult = {description = \" Permission denied\"; flag = NOPERM; result = no; tagId = 6; }; }"; access = NOPERM; reason = " Permission denied"; result = 0; }

I cannot put a single user in the field, I’m unsure if this is by design?? I can put a single user into dovecot-acl:
echo user=dlloyd@domain.com keilrwts >> /var/lib/nethserver/vmail/vmail/Maildir/.FAX/dovecot-acl

which clears the issue and the error does not appear, but the group does not allow me to see it, nor can I enter a single user into the Nethserver GUI, Am i looking in the wrong place?? I’ve been reading documentation but there seems to be very little (or I can’t find it) on setting up a shared mailbox.

/var/lib/nethserver/vmail/vmail/Maildir/.FAX/dovecot-acl contents after adding in Nethserver
group=MemberInThisGroup@domain.com keilrwts

I am a member of the group.

Thanks for any pointers


Error on Sogo when accessing parent of shared mailboxes
Nethserver email alias dynamic when using groups
(Jeroen Visser) #2

Shared mailboxes just worked out of the box for me. I have Samba AD, it’s irrelevant if it is on the same server or not … had both, both worked.

  1. create group
  2. create shared mailbox, add a group to it
  3. add user to group
  4. log out and back in to SOGo
  5. profit …

It seems you did the same … except you use LDAP… not sure if that could be the issue …