Shared folders not working with WIN 10

sharedfolders
activedirectory
v7

#1

Hello everybody, I hope that you are all well :slight_smile:

I can access SMB shared folders from all computers, mobile phone… it works fine,

Unless I am using windows 10 , with computers running win 10, shared folders on nethserver 7 or 7.5 are not accessible, credentials do not work,

The computers have not joined the domain, they connect to shared folders with user and password

Have you come across this probleme?
What do I need to change in wondows 10 to be able to connect to my shared folders?

Thank you for your help on this :slight_smile:


(Markus Neuberger) #2

Hi @omega,

did you try to connect with “DOMAIN\username” ?

http://docs.nethserver.org/en/v7/shared_folder.html#network-access

You may try to use IP or servername to connect to your shares.

Maybe you have faulty credentials in Windows cred manager?

https://support.microsoft.com/en-us/help/4026814/windows-accessing-credential-manager


#3

Hello,

Thanks fir the reply,:slight_smile:

Yes i tried all this, its only with computers running W10, 3 PC , that all of them have the same probleme. I can accesswith computers running w7, phoned with android and ios are also ok.
It is somerhing withing W10 causing the problem.
Tried domain\log
Tried ip name of server, nothing works
Credentials are also ok, flushed them, and entered name/password again…
Nothing works.
3 computers with w10 having these problem, surely someone else had trouble with w10 accessing SMB SHARES.
W10 heve not joined the domain, use NS for SMB and vpn:)


(fpausp) #4

Is there a special reason to not join the pc to the domain?
I would say if you join the pc to the domain it will work…


#5

Hello,

Well, i have not a use tojoin a domain.
And other computers work without joining domain.
It is just SMB shares…
:slight_smile:


(Marc) #6

Don’t know if this bug is related.
Which Windows 10 version (home, pro…) and which release (1803…)?
Do you get any error message on Windows 10 and/or in the server logs?
Do they try to access the share from local or through the VPN?


(Jan Jacobs) #8

This has probably to do with Microsoft’s discision to disable SMBv1, there is a powershell command to enable SMBv1 or you can use the programs and features option in the control panel :slight_smile: Please enable SMBv1 and let us know the results :slight_smile:


#9

Hello, this is still not working and I am getting this in the samba log.

[2018/06/12 23:36:10.227244, 0] …/source3/auth/auth_domain.c:226(domain_client_validate)
domain_client_validate: unable to validate password for user diego@mikroeko.lan in domain to Domain controller NSDC-SERVEUR.AD.MIKROEKO.LAN. Error was NT_STATUS_WRONG_PASSWORD

THE THING IS, THE PASSWORD IS CORRECT AND WORKS FROM A WINDOWS 7 MACHINE.

SOMETIMES ENABLING 40 and 56 BITS ENCRYPTION IN W10 WORKED BEFORE? BUT NOT ANYMORE

SAMBA V1 IS ENABLED

I can access the SMB folders if I give access to guest , that is without needing a log/password

Any ideas ?

Thanks for your help :slight_smile:

EDIT: I found this;
https://superuser.com/questions/1125438/windows-10-password-error-with-samba-share

Will try it :slight_smile:

EDIT 2: OK what worked for me is :slight_smile:

Send NTLMv2 response only. Refuse LM

EDIT 3: it does not work again…