Set authentication credentials for LDAP applications

I have the same problem. AD Local. after upgrading it asks me “Set authentication credentials for LDAP applications Some applications require simple LDAP authentication credentials to browse the AD LDAP database and work properly.”

the server is in operation with created users … :frowning:

2 Likes

Could you attach a screenshot of Accounts provider page?

Also the complete /var/log/messages could help

A local AD provider shouldn’t need to display that message. I found a similar issue on some machines and filed a bug

Can you find similar errors in the messages log?

The bug should not harm running services because previous LDAP credential settings are retained

 account-provider-test dump
3 Likes

1 Like

Would you like testing the bug fix?

Who has said fear?

2 Likes

You should be able to install the update using this command:

yum install http://packages.nethserver.org/nethserver/7.4.1708/autobuild/x86_64/Packages/nethserver-dc-1.4.1-1.3.pr72.geca2a1c.ns7.x86_64.rpm

Relate PR: https://github.com/NethServer/nethserver-dc/pull/72

i installed the bug fix, seems to work very well

4 Likes

The notification has disappeared, testing …

2 Likes

The package is now available from testing repo too:

 yum --enablerepo=nethserver-testing update nethserver-dc

I’ve tested on 4 production servers successfully (with and without the bug) :champagne:


edit: fix released in updates repo, with

nethserver-dc-1.4.2-1.ns7.x86_64.rpm
3 Likes