Server-manager not accessible and network connection lost

I have the same problem after fresh installation, with some mysterious issues

  1. Access to Nethserver-GUI from the well used interface enp3s0 (used for installing, upgrading Centos, upgrading to kernel 5.x, Nethserver-installation) fails after NethServer installation.
  2. I tried to switch to the second interface enp2s0 - that was down. I activated it inside etc/sysconfig/network-scripts/ifcfg-enp2s0 an after rebooting this port is also active
  3. Access to the NethServer-GUI is still impossible

my analysis:

than is started the service

What is happened with the fresh installation? How could I fix this misbehavior?

httpd: Could not open configuration file /etc/httpd/admin-conf/httpd.conf: No such file or directory

Logs may show some errors on nethserver-httpd-admin installation. Seems template files were not expanded and the service was not enabled and started.

You can try to fix it with:

signal-event nethserver-httpd-admin-update

If still doesn’t work:

yum reinstall nethserver-httpd-admin

Also check httpd package was installed.

OMG, I’m blind.

[root@nethserver ~]# signal-event nethserver-httpd-admin-update
[root@nethserver ~]# systemctl -l status httpd-admin
â—Ź httpd-admin.service - Server Manager UI httpd instance
   Loaded: loaded (/usr/lib/systemd/system/httpd-admin.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fr 2020-01-24 18:19:07 CET; 8s ago
  Process: 2842 ExecStart=/usr/sbin/httpd -f /etc/httpd/admin-conf/httpd.conf -c MaxConnectionsPerChild 12 -DFOREGROUND (code=exited, status=1/FAILURE)
 Main PID: 2842 (code=exited, status=1/FAILURE)

Jan 24 18:19:07 nethserver.home.lan systemd[1]: Started Server Manager UI httpd instance.
Jan 24 18:19:07 nethserver.home.lan httpd[2842]: AH00526: Syntax error on line 62 of /etc/httpd/admin-conf/httpd.conf:
Jan 24 18:19:07 nethserver.home.lan httpd[2842]: SSLCertificateFile: file '/etc/pki/tls/certs/httpd-admin.crt' does not exist or is empty
Jan 24 18:19:07 nethserver.home.lan systemd[1]: httpd-admin.service: main process exited, code=exited, status=1/FAILURE
Jan 24 18:19:07 nethserver.home.lan systemd[1]: Unit httpd-admin.service entered failed state.
Jan 24 18:19:07 nethserver.home.lan systemd[1]: httpd-admin.service failed.

Just trying yum reinstall nethserver-httpd-admin

that seems to hang

[root@nethserver ~]# yum reinstall nethserver-httpd-admin
Geladene Plugins: changelog, fastestmirror, nethserver_events
Loading mirror speeds from cached hostfile
 * base:
 * centos-sclo-rh:
 * centos-sclo-sclo:
 * elrepo:
 * elrepo-extras:
 * elrepo-kernel:
 * epel:
 * extras:
 * nethforge:
 * nethserver-base:
 * nethserver-updates:
 * updates:
nethforge/7/x86_64/signature                                                                                                                                                                                             |  836 B  00:00:00
SchlĂĽssel wird von file:///etc/pki/rpm-gpg/RPM-GPG-KEY-NethForge-7 geholt
GPG-SchlĂĽssel 0x39BAF5C1 importieren:
 Benutzerkennung     : "NethServer 7 (NethServer 7 Official Signing Key) <>"
 Fingerabdruck: 594c 3fd8 fae1 8ff5 32fe ae23 9cb2 8ea0 39ba f5c1
 Paket    : nethserver-nethforge-release-7-3.ns7.noarch (@nethserver-base)
 Von       : /etc/pki/rpm-gpg/RPM-GPG-KEY-NethForge-7
Ist dies in Ordnung? [j/N] :j
nethforge/7/x86_64/signature                                                                                                                                                                                             | 3.6 kB  00:00:02 !!!
(1/2): nethforge/7/x86_64/group_gz                                                                                                                                                                                       | 1.7 kB  00:00:00
(2/2): nethforge/7/x86_64/primary_db                                                                                                                                                                                     | 102 kB  00:00:00
Abhängigkeiten werden aufgelöst
--> TransaktionsprĂĽfung wird ausgefĂĽhrt
---> Paket nethserver-httpd-admin.noarch 0:2.4.0-1.ns7 markiert, um reinstalliert zu werden
--> Abhängigkeitsauflösung beendet

Abhängigkeiten aufgelöst

 Package                                                           Arch                                              Version                                                   Paketquelle                                                Größe
 nethserver-httpd-admin                                            noarch                                            2.4.0-1.ns7                                               nethserver-base                                            1.6 M

Neu installieren  1 Paket

Gesamte Downloadgröße: 1.6 M
Installationsgröße: 5.2 M
Is this ok [y/d/N]: y
Downloading packages:
nethserver-httpd-admin-2.4.0-1.ns7.noarch.rpm                                                                                                                                                                            | 1.6 MB  00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installieren     : nethserver-httpd-admin-2.4.0-1.ns7.noarch                                                                                                                                                                              1/1
  Überprüfung läuft: nethserver-httpd-admin-2.4.0-1.ns7.noarch                                                                                                                                                                              1/1

and lost my network connection:

ping                                                                                                                                                                      PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2

…also after rebooting NethServer :frowning:

ifconfig on the server gets the right port information.

I don’t have any idea.

Thank you for your support.

  1. I installed new and upgraded to the current Kernel 3.10.x
  2. One modification I have done: inserted Grub parameter “intel_idle.max_cstate=2”
  3. I have installed the CentOS basic system with a configuration change: the automatic port detection during the boot process has been activated. If I missed this in previous installations, the ports were inactive and did not receive DHCP IP
  4. Updated the system and installed some tools
    yum install nano wget curl net-tools lsof bash-completion mc
  5. Netserver 7 installation via net
  6. The installation ends with on my ssh console with Created symlink from /etc/systemd/system/ to /usr/lib/systemd/system/nethserver-config-network.service. and the ssh connection hangs.
  7. on my directly connected monitor I found one error:
    [283.989171] EDAC pnd2_ failed to register device with error -22
    [284.001485] EDAC pnd2_ failed to register device with error -22
    [284.011171] EDAC pnd2_ failed to register device with error -22
    [284.021446] EDAC pnd2_ failed to register device with error -22

I didn’t found any explanation in the net for.

cat: /var/log/nethserver-install.log
…no errors…last row ends with “End”
8. Resume:

  • the System is not ping-able
  • my ifcfg-en2s0 still exists, also including ONBOOT=yes
  • my ifcfg-en3s0 is deleted

Does anybody have an explanation for this and a tip?

I don’t understand this, because my installation some days before (including Kernel 5.x) worked properly.

I don’t know anything about EDAC (Error Detection And Correction) but this is what I found:

Linux kernel’s EDAC subsystem (previously known as Bluesmoke), which collects the data from error-checking-enabled components inside a computer system; beside collecting and reporting back the events related to ECC memory, it also supports other checksumming errors, including those detected on the PCI bus.

Just before those EDAC error lines, you shall find some related error (maybe related to BIOS/device/driver… i.e. BIOS setting, Bluetooth/Wi-Fi, missing EDAC configuration, etc.) by grepping dmesg

pnd2 might refer to Pondicherry2 memory controller.

Yes, the general Informationen I found too; but not error specifically.
For me, it sounds like a new upcoming hardware problem, because my former installation was easy.
I will analyze it deeper.

Does any principle restriction exist to use my hardware or is she well supported by Red-hot/Centos?

It is my second attempt with Nethserver…

If the hardware problem persists I think about an alternative system:

Is this system supported by Centos/Nethserver?

I switched to the newer thread…

@dnutan I installed the system new on a different hardware - same result. After the installation of Nethserver lost my network connectivity.

db networks show

gateway= (correct)

httpd-admin is active

Did the development team change anything in the installation script? Last week I was able to install without such problems.


Did the development team change anything in the installation script? Last week I was able to install without such problems

Is there any chance to get an answer?

I don’t know. I think they did not, unless there’s is an update (firewall or other package) related to your issue. You can track recent updates from Updates for NethServer 7.7.1908

Sorry I can’t try new install at the moment.

Note: moved some of your posts to a new thread to get it better organized and reducing cross-posting.

EDIT: for the network connectivity problem you could try clearing the firewall rules:

shorewall clear

Clear will remove all rules and chains installed by Shorewall. The firewall is then wide open and unprotected. Existing connections are untouched. Clear is often used to see if the firewall is causing connection problems.

1 Like

No changes were made on the installation part.

1 Like

Hello everyone, the mystery has been solved.
In my desperation, I reloaded the installation ISO and burned it - now the installation went through without any problems, even in one go. Before I had to install Centos basic first and then Nethserver via netinstall.
Maybe my ISO wasn’t fresh anymore and the Centos basic installation didn’t fit to the nethserver installation from the net repository.
But I still don’t understand why I was able to install even with ELREPO-Kernel 5.x after the old step-by-step procedure last week. But it doesn’t really matter.
Now I have a standard installation running on a ZOTAC ZBOX CI327 nano and hope I only have configuration problems. On the second ZBOX now runs Linux Mint with PIHOLE - a wonderful combination of both systems.
Thank you for your patience with me!

1 Like