Scan on Shared Folder


i have a customer with a Olivetti Printer and the scan to a shared folder on nethserver doesn’t work, i think because the printer use smb 1.0 and nethserver non support on default.

What is better to do activate smb 1.0 on nethserver or use ftp protocol to do the scan?

Is possible to enable ftp on shared folder?


I think FTP is the easier way. Also it is faster then SMB. From security side, both are not encrypted.

ok what should i do just install the ftp server package and then how can i access a shared folder via ftp?

You have to install Webserver. At the application menu you have to click at webserver settings. Now you can choose FTP at the menu on the left and add FTP Server. After doing this you can create FTP Users. If you activate chroot users at home directory (at advanced settings) the user only has access to his own home folder.


Is possible to send the scan to home user folder?

I found this on another topic on this forum

I create an ftp user and a shared folder with guest access with read and write permission and the scan it works.

but by doing so, even a non-domain user can access the “scan” folder right?

Yes, you are right. Do you have an AD? So you can try the following, if you don’t use the webserver:

Yes i have a domain

i try to following your link but i don’t understand very well what should i do.

otherwise is it possible to activate support for smb 1.0 and 2.0?

You can try with

min protocol = SMB1

Create a a custom template at


name it for example 11protocol and add the following content

# 11protocol
# Setting miniimum smb protocol
min protocol = SMB1

After that you have to expand your template.

template-expand /etc/samba/smb.conf

If you want to check if the expansion has worked, have a look at


You should find your template fragment at the file.
More information about templates you can find at:



i create a file smb.conf in this path /etc/e-smith/templates-custom/etc/samba/

whit this content:

# 11protocol
# Setting miniimum smb protocol
min protocol = SMB1

and after expand the template with this command:

expand-template /etc/samba/smb.conf

but if i put cat /etc/samba.smb.conf i see only this content:

# 11protocol
# Setting miniimum smb protocol
min protocol = SMB1

what did i do wrong?

I did not understand

now I have created the file 11protocol in this path /etc/e-smith/templates-custom/etc/samba/smb.conf/

but the scan not work

and clients on the network can no longer access shared folders.

now I have deleted the file created and everything is back to working

I do not know the reason

Did you expand the template?
Please show us the content of the following file:


You should setup a virtual machine for testing purpose. If you don’t have virtualized anything till now, try virtual box at a client. With a Test-Machine everything else don’t stop working, if something went wrong.


At the moment I leave everything as it was before, the smb.conf file is currently as it was before the modification and in fact everything works.
However, the customer will soon change printers and perhaps this will also support the latest samba protocol.

However I don’t know why with that file change the clients could no longer access the shared folders, ftp scanning worked the problem is I didn’t like the fact that anyone could get into the folder.

Thanks for the support anyway

1 Like