Samba 4 no ad, but Workgroup

accounts-provider
v7
activedirectory

(Stojovski) #1

In Neth 6, I can choose what I want, but here it muss be a ad server.
Some small networks does not need an Activedirectory, but Workgrou with ACL.
And when I use a Workgrop in Samba, i muss alwayslogin with user@server.local, home folder lokks than like user@server.local.Very frustrating.
Does someone have an Idea?THX to all.


(Davide Principi) #2

We discussed this topic in this forum in the past, please search past discussions!

Also this discussion might be interesting


#3

Hi,

I just terminated to download a CENTOS 7 minimal install.
Today or this week-end, I will create the USB stick and doing again my Nethserver instance…

But I didn’t understand well the initial post…

“I must always login with user@server.local”… Yes, sure… And what is the problem?
With Windows, MacOs, Linux… There always the possibility to make a network connection permanently.
Or I understand the question incorrectly?


(Stojovski) #4

THX Davide, but this does not help, i must alway for every user , maybe 20 an smbpasswd -a und smbpasswd -e than restart, and than works, but this is really poor, than i can install Debian, or pure CentOS 7, or debian or CentOS with ispconfig ,inkluded Active sync.The goal why we try Nethserver, is that it works, and maybe do some changes , and the possible customers buy a Commercial support.I like it very much, but i am dissapointed from Version 7, the old one works PERFECT.Also Sogo 3 , it’s very buggy.you have a 2 buttons to delete mails, an one does not work. hmm, i don’t know why, it worked before last update.


(Stojovski) #5

I tryed, and I can not Login with user@server.local either.
I don’t want an AD server, maybe you can understand now?

And I don’t know why the Linux is not so easy like Ubuntu.CentOS installs always LVM, why , not all needs LVM, it is just nit OK.I would prefer Debian for all this stuff, it’s just easy and you know what you do with partitioning and so on.I am dissapointed very much from Linux Red Hat(CentOS).I can say that I am a experience user admin, but this changes makes Linux MS saw that, and it uses.Cheap server 2016, Mailserver and so on.I don’t like Windows on Server, but what Linux Community makes makes me very unstable.The only Debian does not changes everything, it’s just rocking.


(Rob Bosch) #6

I dont have this problem. I use Elementary OS (v0.4 Loki) on my laptop and log in with my Samba4 AD account and only need to type my username (rob) and my password. I never need to pass credentials when I access a Samba share.

Maybe I misunderstood your problem?

For your rant on RedHat/CentOS: you will need to get used to a different way of managing packages. I come from Ubuntu myself and had a hard time first too. Only thing I can say: read a lot and experiment even more. Set up some NethServer instances in VirtualBox or something similar. Follow some of the many howto’s in our wiki to install extra software. It gives you insight how CentOS works.

Best advice I can give is to not give up that easily and if you bump into a problem you can not solve yourself, just ask. We are here to help.


(Davide Principi) #7

I’m happy to hear ns6 is perfect :heart_eyes: I expect a system reaches a mature/stable point during its life cycle. Being considered perfect is a big goal.

Ns6 development started in 2011, based on CentOS 6.2. It was an era ago. The 6 branch eol will be in three years: 2020. In the meantime ns7 can grow and expand its capabilities, thanks to this community efforts.

I’d like to answer those like you who ask the old-times super-simple workgroup mode. I think it cannot be like it was on ns6, though. We must find another way… In any case we know that many parts of the smb protocol have been attacked during these years and latest systems have them disabled. For this reason I consider this exercise a legacy device support effort, it’s not a main line of development.


(Stojovski) #8

Thank you robb, i don’t give up so easy, but i think that you speak about LDAP user manager.And there you can only make a Share r/w for everyone.That’s not what i want.I have tryed all, but i can not login with Samba Userv Manager.I used CentOS for many years before, than used only Debian. I think that Red Hat/CentOS are very ok, it is just habit.I’ll try to login with Ubuntu.


(Stojovski) #9

Yes, it just rocks for me.First time a tryed nethserver 6 i was really very very immpressed. specialy the Mail Server, just perfect.Bow down for programmers :relaxed:


(Stojovski) #10

Good news, after 3-4 new installs, it worked for me.Everything OK.THX on all.


(Rob Bosch) #11

Would you mind to share with us what made it work? What did you do differently compared to earlier tries?


(Stojovski) #12

Hi Robb, of course, i tried many times.First of all, after new install normal setup with web GUI, than all updates, over web GUI not Terminal, reboot, than installed Account Provider Samba, than Samba. But all software individually installed.Alway reboot.After I finished, installing all the stuff I configured group, and than the users…And I could manage to log in with domainname\user and password without Joining a Domain.
And it works great now.