Root Mail Address

roundcubemail
v7
mail

(Federico Ballarini) #1

NethServer Version: 7.5
Module: Email

Is it possible to not receive any email on root@ account?
Because I already receive emails an admin@ account…

Thanks.


(Eddie Atherton) #2

Davide’s post here shows how to route root’s mail to a different user.

Cheers.


(Federico Ballarini) #3

But emails already arrive to other user… but today I opened root mail and there was 200 mails…


(Eddie Atherton) #4

That were originally addressed to root ??

Do you recognise what sent them.

Cheers.


(Federico Ballarini) #5

Yes, they were originally addressed to root.

Emails that appears also in root mail are sent from root.


(Eddie Atherton) #6

In my notes, I have the following:

Move (not copy) mail from root -> admin
---------------------------------------
config setprop root KeepMessageCopy no

Unfortunately, I can’t remember where I originally saw this mentioned.

Cheers.


(Federico Ballarini) #7

In your opinion if I try config command, emails are deliver to admin but not conserved in root?


(Federico Ballarini) #8

I’ve tried but emails arrives also in root…


(Eddie Atherton) #9

Back to (sorta) the original questions.

How are you re-directing the mails originally sent to root to the alternative address.

What is sending the mails.

And to clarify what you are saying: All the mails redirected from root to the alternate address are retained in root as well as being forwarded.

Cheers.


(Federico Ballarini) #10

With the profile page where there is “External email address option”

The system… with root account.

A question… after this command

I have to execute a singal-event command? If yes, what command?

Thanks.


(Eddie Atherton) #11

Almost certainly.

I don’t know, sorry. Perhaps @davidep or @giacomo can help.

Cheers.


(Federico Ballarini) #12

I’ve try to set to “no” KeepMessageCopy but it doesn’t works…
Anyone can help me?


(Marc) #13

Not sure but maybe:

signal-event nethserver-mail-server-update

or

signal-event nethserver-base-update

(Davide Principi) #14

Or

signal-event nethserver-base-update

(Federico Ballarini) #15

If I do a backup (data) with send an email to root, the email has to arrive to admin and not keeped in root mail, correct?


(Federico Ballarini) #16

It’s configured properly, but it doesn’t works…


(Davide Principi) #17

Let’s see

 grep root /etc/aliases

(Federico Ballarini) #18

postmaster: root
bin: root
daemon: root
adm: root
lp: root
sync: root
shutdown: root
halt: root
mail: root
news: root
uucp: root
operator: root
games: root
gopher: root
ftp: root
nobody: root
radiusd: root
nut: root
dbus: root
vcsa: root
canna: root
wnn: root
rpm: root
nscd: root
pcap: root
apache: root
webalizer: root
dovecot: root
fax: root
quagga: root
radvd: root
pvm: root
amandabackup: root
privoxy: root
ident: root
named: root
xfs: root
gdm: root
mailnull: root
postgres: root
sshd: root
smmsp: root
postfix: root
netdump: root
ldap: root
squid: root
ntp: root
mysql: root
desktop: root
rpcuser: root
rpc: root
nfsnobody: root
ingres: root
system: root
toor: root
manager: root
dumper: root
abuse: root
webmaster: root
noc: root
security: root
hostmaster: root
decode: root

Person who should get root’s mail

#root: marc
root: admin@domain.ext, root


(Eddie Atherton) #19

That should only be:

root: admin@domain.ext

Not sure what’s adding the additional “root”, which is causing the duplicate.

Cheers.


(Federico Ballarini) #20

@davidep any ideas?