Report Bandwith usage - could not decode ntopng response


Does the report module (Bandwidth usage) only work if Ntopng sets no authentication?
When I enable authentication I get a message "Could not communicate with ntopng. See /var/log/messages for details"
LOG - neth httpd: [ERROR] NethServer\Module\NtopngStatus: could not decode ntopng

System version
NethServer release 7.4.1708


Hi @pablo,

I tested it now on 7.4.1708 and got the same error, maybe something changed from ntop version 2 to 3 but this is not intended I think. The ntopng application is working but Reports/Bandwidth Usage shows this, when authentication is enabled:

After a reboot the already changed password for ntopng admin was reset to default admin.

This one is already raised:

I think you found a bug. Thank you.

1 Like

AFAIK authentication should always be disabled on from localhost.

I will check the code next week and let you know

@mrmarkuz was right, you hit a bug @pablo.

You can find the fixed packaged in nethserver-testing:

1 Like

Thanks for help! :slight_smile:

Thanks for you’re time, we are going to release the update soon! :wink: