Ntop password reset after reboot

After rebooting the server, the password ntop is reset to the default “admin”

That’s odd, probably the cache of redis is gone.

My suggestion is to remove the password, ntopng never worked well with it :smiley:

I have these instructions for my Nethserver NG 6.8, maybe they work on NG 7 too:

Connect to Nethserver shell with root user

First thing is to obtain the MD5 hash of the NTOP password (replace “password.I.want.to.use” with the NTOP password)

# echo -n password.I.want.to.use | md5sum
c74bddb566ffa099264cee4599ea8fc4  -

Copy the MD5 hash (in this case c74bddb566ffa099264cee4599ea8fc4) without the dash then digit:

# redis-cli -p 6378
redis> set ntopng.user.admin.password c74bddb566ffa099264cee4599ea8fc4
redis> get ntopng.user.admin.password
redis> quit

At this point it’s possible to access to NTOP with the password

It’s possible to configure the system to set the correct password one time at week:

# cd /etc/cron.d
# cat ntopng_pwd
5 8 * * 6 root /usr/bin/redis-cli -p 6378 set ntopng.user.admin.password c74bddb566ffa099264cee4599ea8fc4

Remember to modify the last script if the NTOP password is changed with the correct MD5 hash.

Then it is better to change when loading, it is dropped only in case of reset, on standard “admin”

It at me in the Internet shines. Everyone will come to look…:смайлик:

I made a small discovery it makes ntopng work like normal
you need to install ntopng manually first before adding it in the nethserver GUI then enable it in the GUI with no password authentication, it gives an error when started but still works, then when you start it for the first time it asks you to change the password and it stays set and remembers settings
next I will test if it keeps that password after a reboot as well as the serial
then after that I will get my key reset to work with my new hardware and test if it remembers that too after a reboot
will update you soon
rebooting now 07/10/2017/10:34 +10GMT
ok so a reboot totally breaks it trying to fix now
ok it just needs to be started manually am going to try and add it to startup services