PXE setting error

Hi,

http://docs.nethserver.org/projects/nethserver-devel/en/latest/tftp.html

PXE Server do it on this basis.
However, the signal-event nethserver-tftp-save does not run.

The answer is: Can’t open directory /etc/e-smith/events/nethserver-tftp-save

what’s the mistake?

Sorry, online translation.

You need the DNS and DHCP server module from software center, as it integrates tftp.
It seems the documentation is not updated. The commands should be:

config setprop dnsmasq tftp-status enabled
signal-event nethserver-dnsmasq-save

But it is already enabled by default:

config getprop dnsmasq tftp-status
1 Like

Thanks, so the status: Enabled
But I do not see the PXE server.

dnsconf tftp:
"#"
"#" 80tftp
"#"
enable-tftp
dhcp-boot=pxelinux.0
tftp-root=/var/lib/tftpboot
dhcp-option=66,“192.168.132.1”

I created directories
I did everything based on the description,
.

1 Like

Following the example in the documentation (with some minor tweaks):

yum install syslinux
cp /usr/share/syslinux/{pxelinux.0,menu.c32,memdisk,mboot.c32,chain.c32} /var/lib/tftpboot/
config setprop dnsmasq dhcp-boot pxelinux.0
signal-event nethserver-dnsmasq-save 
mkdir /var/lib/tftpboot/pxelinux.cfg
vi /var/lib/tftpboot/pxelinux.cfg/default

Content of /var/lib/tftpboot/pxelinux.cfg/default file (tweak it as needed: i.e. append the repo boot parameter, add menus for other distros, etc.):

@filippo_carletti and @JOduMonT shared some examples (a, b) of how they are using it.

mkdir /var/lib/tftpboot/CentOS

Copy initrd.img and vmlinuz (or the whole images folder content) from ISO to /var/lib/tftpboot/CentOS

Change ownership:

chown -R nobody /var/lib/tftpboot/*

Test pxe server is working by booting a client machine with network boot support:

What remains is to decide where to store the installation files, and how they will be retrieved by the clients (ftp, http, nfs…), tweaking the /var/lib/tftpboot/pxelinux.cfg/default file accordingly.

Note I don’t use it so I might have missed something (uefi…) This was on NethServer 6.8 acting as dhcp server and configuring the ftp server as installation source, just for testing purposes (installing the ftp server module from software center, creating a user, adding the repo boot parameter with the ftp settings to the pxe default file, and copying the installation files over the ftp user path). Hope it helps.:slight_smile:

1 Like

I’ve done everything.
The TFTP work. I test about VirtualBox. You can not find the server.

I’m sorry, operating at normal machine.
I do not know if the virtual machine mia problem.

Thanks for the help.