Problems to install updates


(Uwe) #1

Hi friends,

i cant install updates on my nethserver. I used ```yum --enablerepo=nethserver-updates,updates update

```"
Can somebody help me?

Thanks and regards

Uwe

Loaded plugins: changelog, fastestmirror, nethserver_events
Determining fastest mirrors
 * nethserver-updates: markusneuberger.at
 * updates: centos.mirror.net-d-sign.de
nethserver-updates                                       | 4.1 kB     00:00
sb-base                                                  | 3.6 kB     00:00
sb-centos-sclo-rh                                        | 3.0 kB     00:00
sb-centos-sclo-sclo                                      | 2.9 kB     00:00
sb-epel                                                  | 3.2 kB     00:00
sb-extras                                                | 3.4 kB     00:00
sb-nethserver-base                                       | 2.9 kB     00:00
sb-nethserver-updates                                    | 4.1 kB     00:00
sb-updates                                               | 3.4 kB     00:00
updates                                                  | 3.4 kB     00:00
(1/15): nethserver-updates/7/x86_64/group_gz               |  20 kB   00:00
(2/15): sb-base/x86_64/group_gz                            | 166 kB   00:00
(3/15): nethserver-updates/7/x86_64/primary_db             | 491 kB   00:00
(4/15): sb-epel/x86_64/group_gz                            |  88 kB   00:00
(5/15): sb-centos-sclo-sclo/x86_64/primary_db              | 294 kB   00:00
(6/15): sb-extras/x86_64/primary_db                        | 205 kB   00:00
(7/15): sb-nethserver-base/x86_64/primary_db               | 296 kB   00:00
(8/15): sb-nethserver-updates/x86_64/group_gz              |  20 kB   00:00
(9/15): sb-epel/x86_64/updateinfo                          | 934 kB   00:01
(10/15): sb-nethserver-updates/x86_64/primary_db           | 491 kB   00:00
(11/15): sb-epel/x86_64/primary                            | 3.6 MB   00:01
(12/15): updates/7/x86_64/primary_db                       | 1.3 MB   00:00
(13/15): sb-centos-sclo-rh/x86_64/primary_db               | 3.7 MB   00:01
(14/15): sb-base/x86_64/primary_db                         | 5.9 MB   00:02
(15/15): sb-updates/x86_64/primary_db                      | 6.0 MB   00:01
sb-epel                                                             12725/12725
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:1.10.2-16.el7_5 will be updated
---> Package NetworkManager.x86_64 1:1.12.0-8.el7_6 will be an update
--> Processing Dependency: glib2 >= 2.56.1 for package: 1:NetworkManager-1.12.0-                                                                                                                                                             8.el7_6.x86_64
---> Package NetworkManager-libnm.x86_64 1:1.10.2-16.el7_5 will be updated
---> Package NetworkManager-libnm.x86_64 1:1.12.0-8.el7_6 will be an update
---> Package NetworkManager-team.x86_64 1:1.10.2-16.el7_5 will be updated
---> Package NetworkManager-team.x86_64 1:1.12.0-8.el7_6 will be an update
---> Package NetworkManager-tui.x86_64 1:1.10.2-16.el7_5 will be updated
---> Package NetworkManager-tui.x86_64 1:1.12.0-8.el7_6 will be an update
---> Package NetworkManager-wifi.x86_64 1:1.10.2-16.el7_5 will be updated
---> Package NetworkManager-wifi.x86_64 1:1.12.0-8.el7_6 will be an update
---> Package cronie.x86_64 0:1.4.11-19.el7 will be updated
---> Package cronie.x86_64 0:1.4.11-20.el7_6 will be an update
---> Package cronie-anacron.x86_64 0:1.4.11-19.el7 will be updated
---> Package cronie-anacron.x86_64 0:1.4.11-20.el7_6 will be an update
---> Package device-mapper.x86_64 7:1.02.146-4.el7 will be updated
---> Package device-mapper.x86_64 7:1.02.149-10.el7_6.2 will be an update
---> Package device-mapper-event.x86_64 7:1.02.146-4.el7 will be updated
---> Package device-mapper-event.x86_64 7:1.02.149-10.el7_6.2 will be an update
---> Package device-mapper-event-libs.x86_64 7:1.02.146-4.el7 will be updated
---> Package device-mapper-event-libs.x86_64 7:1.02.149-10.el7_6.2 will be an up                                                                                                                                                             date
---> Package device-mapper-libs.x86_64 7:1.02.146-4.el7 will be updated
---> Package device-mapper-libs.x86_64 7:1.02.149-10.el7_6.2 will be an update
---> Package ipset.x86_64 0:6.29-1.el7 will be updated
---> Package ipset.x86_64 0:6.38-3.el7_6 will be an update
---> Package ipset-libs.x86_64 0:6.29-1.el7 will be updated
---> Package ipset-libs.x86_64 0:6.38-3.el7_6 will be an update
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.191.b12-0.el7_5 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.191.b12-1.el7_6 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.191.b12-0.el7_5 will be                                                                                                                                                              updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.191.b12-1.el7_6 will be                                                                                                                                                              an update
---> Package kernel.x86_64 0:3.10.0-957.1.3.el7 will be installed
--> Processing Dependency: linux-firmware >= 20180911-68 for package: kernel-3.1                                                                                                                                                             0.0-957.1.3.el7.x86_64
---> Package kernel-tools.x86_64 0:3.10.0-862.14.4.el7 will be updated
---> Package kernel-tools.x86_64 0:3.10.0-957.1.3.el7 will be an update
---> Package kernel-tools-libs.x86_64 0:3.10.0-862.14.4.el7 will be updated
---> Package kernel-tools-libs.x86_64 0:3.10.0-957.1.3.el7 will be an update
---> Package lvm2.x86_64 7:2.02.177-4.el7 will be updated
---> Package lvm2.x86_64 7:2.02.180-10.el7_6.2 will be an update
---> Package lvm2-libs.x86_64 7:2.02.177-4.el7 will be updated
---> Package lvm2-libs.x86_64 7:2.02.180-10.el7_6.2 will be an update
---> Package python-paramiko.noarch 0:2.1.1-4.el7 will be updated
---> Package python-paramiko.noarch 0:2.1.1-9.el7 will be an update
---> Package python-perf.x86_64 0:3.10.0-862.14.4.el7 will be updated
---> Package python-perf.x86_64 0:3.10.0-957.1.3.el7 will be an update
---> Package selinux-policy.noarch 0:3.13.1-192.el7_5.6 will be updated
---> Package selinux-policy.noarch 0:3.13.1-229.el7_6.6 will be an update
--> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy                                                                                                                                                             -3.13.1-229.el7_6.6.noarch
--> Processing Dependency: libsemanage >= 2.5-13 for package: selinux-policy-3.1                                                                                                                                                             3.1-229.el7_6.6.noarch
---> Package selinux-policy-targeted.noarch 0:3.13.1-192.el7_5.6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.13.1-229.el7_6.6 will be an upda                                                                                                                                                             te
--> Processing Dependency: policycoreutils >= 2.5-24 for package: selinux-policy                                                                                                                                                             -targeted-3.13.1-229.el7_6.6.noarch
---> Package tzdata.noarch 0:2018f-2.el7 will be updated
---> Package tzdata.noarch 0:2018g-1.el7 will be an update
---> Package tzdata-java.noarch 0:2018f-2.el7 will be updated
---> Package tzdata-java.noarch 0:2018g-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
           Requires: libsemanage >= 2.5-13
           Installed: libsemanage-2.5-11.el7.x86_64 (@anaconda)
               libsemanage = 2.5-11.el7
Error: Package: selinux-policy-targeted-3.13.1-229.el7_6.6.noarch (updates)
           Requires: policycoreutils >= 2.5-24
           Installed: policycoreutils-2.5-22.el7.x86_64 (@anaconda)
               policycoreutils = 2.5-22.el7
Error: Package: 1:NetworkManager-1.12.0-8.el7_6.x86_64 (updates)
           Requires: glib2 >= 2.56.1
           Installed: glib2-2.54.2-2.el7.x86_64 (@anaconda)
               glib2 = 2.54.2-2.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.6.noarch (updates)
           Requires: policycoreutils >= 2.5-24
           Installed: policycoreutils-2.5-22.el7.x86_64 (@anaconda)
               policycoreutils = 2.5-22.el7
Error: Package: kernel-3.10.0-957.1.3.el7.x86_64 (updates)
           Requires: linux-firmware >= 20180911-68
           Installed: linux-firmware-20180220-62.2.git6d51311.el7_5.noarch (@sb-                                                                                                                                                             updates)
               linux-firmware = 20180220-62.2.git6d51311.el7_5
           Available: linux-firmware-20180220-62.git6d51311.el7.noarch (sb-base)
               linux-firmware = 20180220-62.git6d51311.el7
           Available: linux-firmware-20180220-62.1.git6d51311.el7_5.noarch (sb-u                                                                                                                                                             pdates)
               linux-firmware = 20180220-62.1.git6d51311.el7_5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

(Davide Principi) #2

You have a subscription: why do you want the updates from community repositories?


(Uwe) #3

Hi Davide,

yes i have a subscription. But for weeks there are no updates here.


(Davide Principi) #4

It’s normal: there are no updates on 7.5 repositories since we started the development of 7.6. Don’t worry: there will be soon!

If you’re hurry, it’s possible to upgrade to 7.6 beta. I wouldn’t recommend it unless strictly necessary or for development purposes.


(Uwe) #5

Ok, thank you. I will wait for 7.6 final.


(Davide Principi) split this topic #6

A post was split to a new topic: 7.6 subscription release date