Problem with CentOS 6.9 updates

NethServer Version: 6.8
Module: nethserver-directory-2.3.0-2.ns6.noarch

when I try to update I have the following error:

Error: Package: nethserver-directory-2.3.0-2.ns6.noarch (@nethserver-updates)
Requires: perl-LDAP = 1:0.40-2.nh
Removing: 1:perl-LDAP-0.40-2.nh.noarch (@nethserver-base)
perl-LDAP = 1:0.40-2.nh
Updated By: 1:perl-LDAP-0.40-3.el6.noarch (centos-base)
perl-LDAP = 1:0.40-3.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Thank you

1 Like

i have the same error.

Could be related to this Centos 6.9 has been released ?

Did you made the update to CentOS 6.9 before?

yes i think it’s related to 6.9 it seems that perl-LDAP that was in nethserver-base
conflict with the new in centos-base repo

Updates to CentOS 6.9 (PERL):

i don’t know why nethserver-directory don’t use perl-ldap from centos, probably some customization…

1 Like

This is the customization. It was required to make “ldapi:///” work in el6 branch and I must re-apply that patch now that they released a new perl-LDAP version.

Let me say it: damned forks!

1 Like

Please see if installing this package from nethserver-testing fixes your issue:

yum --enablerepo=nethserver-testing update perl-LDAP nethserver-directory

You could then proceed to the Software Center page and update NethServer as usual.

Edit: added also nethserver-directory to the update list

Yes it works for me.
many thanks


Yum update (1) before “yum --enablerepo=nethserver-testing update perl-LDAP nethserver-directory” and after (2).

No errors after.

1 Like


1 Like

Looks fixed, thank you all @Ale @ohifra @sankike @GG_jr

1 Like