Which is the best way to block only CentOS updates

,

Today’s updates for NS 6.8 - Final:

My NS is in production as multi domain email server. I don’t think I will make the updates. :grin: Yet!

This could be related to those updates?

Problem with CentOS 6.9 updates

PS:

Which is the best way to block only CentOS updates?

PS2:

BUZZ (Cherry pick updates in Software Center)? :wink:

Disable “updates” repository under /etc/yum.repos.d/

Please see Which is the best way to block only CentOS updates

1 Like

Sorry!
Which and how? CentOS-Base.repo? :pensive:

TIA,
Gabriel

Sorry, I forgot in ns6 the repository configuration is different!

The file to change is

/etc/yum.repos.d/NethServer.repo

And the repo to disable are both centos-base and centos-updates. Don’t forget to enable them in the future!

1 Like

OK!

Thank you again!

I put # in front of [centos-updates] and now in Software Center I have only these updates:

With both disabled, I have this:

You have an error in your .repo file. Maybe DOS CR+LF end-of-line?

Please note that by disabling those repositories you cannot install new modules because required dependencies are not available any more!

I did a enabled=0 and that works fine for me

1 Like

I only put # in front of both.

Works fine with enabled=0 as @flatspin did.
Nothing in Software Center.

I understand that but is better than put down the server!
For the moment, till we will test the upgrade. As I said, my NS is in production.

Edit:

Or, even there are updates, I will not make them.

Thank you all!

I think the best thing to do is

do nothing!

…and wait until

BETTER!