Problem to open a document in Nextcloud Office

Hello developers,

I have installed NS 8 with Debian 12 as substructure on my Proxmox. Initially only as a leader node with Samba AD on it. Nothing else. Now I had the idea to add another machine with NS8 (also Debian 12 as substructure) as a node and install Nextcloud and Collabora on it. I have set up everything, added LE certificates and have access to the NC instance and also to the Collabora admin page. However, if I now want to open a document (whether a Word or Excel file), the message shown in the picture appears and the file does not open immediately. After what feels like 20 seconds, the file does open and can be edited without any problems. In one of my earlier attempts with NS 8 and Rocky 9.2 as a substructure with only one Leader Node, this worked without any problems with the same settings.



Error_2 Collabora

Can you assign more CPUs to it? From what you wrote I feel the node has few CPU power.

I must say that in general Collabora online editing is not really fast: we must take into account also the network and the browser speed

Hi @transocean

Was your “earlier” attempt with NS8 and Rocky done on the same Proxmox host with the same settings?

My 2 cents

Hi Andy,
yes, it is the same Proxmox. However, I only used the Leader Node back then.



Hi @davidep

I have given the node a CPU with four cores and 10240 MB RAM. More CPU is not possible

@transocean would you please share which is your “phisical” CPU on your node, and… more info about your current hardware and virtual hardware setup?

Hi @pike

physical hardware is this: ODROID-H3+ – ODROID

And virtual HW ist this:

KVM + ZFS + NS8 + NextCloud + NextCloud Office… on this hardware seems a bit too much.

SSD can help to reduce latency due to disk access and transfer rate, however… All this slices are not that thin to chew.
I know that seems counter-intuitive, but I’d try to lower the cores on the NS8 guest, allowing Proxmox to have more grunt to manage the underlying processes.
I’d won’t go on three cores, however into the history some processor had (AMD…).

The problem was solved by changing the underlying OS from Debian 12 bookworm to Rocky Linux. In addition to login to Webtop, collabora now also runs smoothly and at a good speed.



the question is, why does it not work on debian but works on rocky

Unfortunately, I’m not deep enough into the subject to be able to answer the question. But the fact is that the problems I described earlier have disappeared from the face of the earth since I switched to Rocky Linux.



can you try to replicate the said error if you deploy another server with the parameters as before

I have already done this by installing three additional nodes and integrating them as workers. Nextcloud and Collabora on one, Webtop and Mailserver on the second and Mattermost on the third. Nothing really worked. Now I have installed everything on a Leader Node (Rocky) and everything is running fine.

@transocean you replaced Debian with Rocky Linux into the VM?
I got it correctly?

AFAIK the VM image released by Nethesis for NS8 was exactly Rocky Linux based…

Is it possible that the change from samba to openldap has something to do with the performance increase and the lesser problems (or that was on another node)?


may be. I will test it later with Sanba.


I did not use the ready-made VM image, but installed the respective OS as a VM.

May I suggest to put into docs this experience. This is the wording I’d use.

If you’re considering to install in any virtual environment NethServer 8, some users experienced better performances using Rocky Linux instead of Debian 12.
Also, the pre-made VM image is Rocky Linux based.

Just a simple… feel free to elaborate, modify, make it compliant with the current wording and style.

Thanks @transocean


That’s ok for me for now. But we should wait until I have a second test machine with Samba-AD later. Maybe Debian wasn’t the brake at all, but it was due to the change of account provider.

After a further test with a new virtual machine (OS Rocky) and Samba-AD as account provider, I can confirm that all applications that previously did not work under Debian 12 are running flawlessly and at a good speed. At the moment these are Collabora, Mailserver, Mattermost, Nextcloud and Webtop. Opening documents with Collabora works well. I installed Webtop normally from the software center and not with the command that @stephdl posted here.

1 Like