Password problem with BackupPC


(Jose "Martin" Abeleira. AKA Marto) #1

It worked like a charm, but login is not working, i’ve changed the password
several times.

Any ideas?

that’s shown on error log.

Tue Mar 24 21:47:37 2015] [notice] Apache/2.2.15 (Unix) DAV/2 configured –
resuming normal operations
[Tue Mar 24 22:01:45 2015] [error] [client 127.0.0.1] user backuppc not
found: /BackupPC
[Tue Mar 24 22:02:03 2015] [error] [client 127.0.0.1] user backuppc not
found: /BackupPC


Backuppc Installation HowTo
Backuppc Installation HowTo
Backuppc Installation HowTo
(Stéphane de Labrusse) #2

Use the admin user and think to set a password to this user if you use a 6.6 version


(Michele Bortolotto) #3

grep backuppc /etc/BackupPC/config.pl

and paste it :wink:


(Jose "Martin" Abeleira. AKA Marto) #4

[root@NetherUruguay ~]# grep backuppc /etc/BackupPC/config.pl

See http://backuppc.sourceforge.net.

$Conf{BackupPCUser} = ‘backuppc’;

$Conf{ServerInitdPath} = ‘/etc/init.d/backuppc’;

$Conf{EMailFromUserName} = ‘backuppc’;
link => “http://backuppc.wiki.sourceforge.net”,
link => “http://backuppc.sourceforge.net”,
[root@NetherUruguay ~]#


(Jose "Martin" Abeleira. AKA Marto) #5

It doen’t work also, user is not shown on neth admin.

But if i change password from ssh to the user and set a shell, it allows me
to login through ssh, but not to access the web


(Stéphane de Labrusse) #6

The only user able to use the cgi interface is the user ‘admin’. Other users who are registered in the ldap database can perform a login, but they are not admin… and What I’m sure is that backuppc is not in the ldap database.

if you have a doubt about a user exists or not, you can use the nethgui, or ‘slapcat’ in you Terminal and look about it.


(Jose "Martin" Abeleira. AKA Marto) #7

user exist, but can’t login to the /backuppc through web, using ssh it
works, seems that its not taking the “htpasswd -c
/etc/BackupPC/apache.users backuppc”


(Stéphane de Labrusse) #8

Well I suspect a big misunderstanding, I did a rpm http://mirror.de-labrusse.fr/nethserver/nethserver-BackupPC/ that needs the user admin, but it never takes its sources from htpasswd. the password needs to be set in ns6.6 and in ns6.5 it is the same than the root password.


(Jose "Martin" Abeleira. AKA Marto) #9

Nop, i also tried with root and admin, and can’t login.


(Stéphane de Labrusse) #10

well the rpm is not finished, we will try to debug after.
What errors you have in logs (/var/log/httpd/error_logs or /var/log/messages and /var/log/httpd-bkpc/) and also what is the output of

rpm -qa | grep -i backuppc


(Jose "Martin" Abeleira. AKA Marto) #11

[root@NetherUruguay ~]# rpm -qa | grep -i backup
BackupPC-3.3.0-2.el6.x86_64
nethserver-backup-data-1.1.2-1.ns6.noarch
nethserver-BackupPC-1.0.0-3.ns6.noarch
nethserver-backup-config-1.4.0-1.ns6.noarch

[root@NetherUruguay ~]# tail -n5 /var/log/httpd/error_log
[Wed Mar 25 22:14:38 2015] [notice] Apache/2.2.15 (Unix) DAV/2
mod_ssl/2.2.15 OpenSSL/1.0.1e-fips configured – resuming normal operations
[Wed Mar 25 22:15:38 2015] [error] [client 192.168.184.201] File does not
exist: /var/www/html/backuppc
[Wed Mar 25 22:15:46 2015] [error] [client 192.168.184.201] File does not
exist: /var/www/html/BackupPc
[Wed Mar 25 22:15:50 2015] [error] [client 192.168.184.201] File does not
exist: /var/www/html/BackupPc
[Wed Mar 25 22:15:59 2015] [error] [client 192.168.184.201] File does not
exist: /var/www/html/Backuppc
[root@NetherUruguay ~]#

[root@NetherUruguay ~]# tail -n5 /var/log/httpd-bkpc/bkpc_error_log
[Wed Mar 25 22:14:26 2015] [notice] Apache/2.2.15 (Unix) DAV/2 configured
– resuming normal operations


(Stéphane de Labrusse) #12

ns6.6 or ns6.5 ?

if it is ns6.6, is it installed from base or upgraded from ns6.5…a bit of history is needed here, it seems workable for other but not for you ???
Moreover you have not caught the error login here, just some log noise.


(Michele Bortolotto) #13

@mabeleira if backuppc was installed using the @stephdl package you do not have to follow my installation howto(for you it’s usefull only on the windows clients configuration part)


(Jose "Martin" Abeleira. AKA Marto) #14

6.6 installed from scratch, using the rpm for nethserver


(Stéphane de Labrusse) #15

Not tested with ns6.6 installed from scratch…just a quick test with an upgraded version but I have no password problem.


(Alessio Fattorini) #16

Please guys @stephdl @mabeleira @AbsyntH can you use the correct thread?
I moved all discussions here, please reply to this topic :smiley:


(Michele Bortolotto) #17

@stephdl i’ll try this evening with a fresh 6.6 installation… @alefattorini PRLLLLLLLLLLL


(Michele Bortolotto) #18

ok @mabeleira i’ve just tried a fresh installation of 6.6 and backuppc from @stephdl repo and it works without any problems, i think you have mixed up two howtos that are intended to be following for two different type of installation , if you can’t go back we can try to fix your problem


(Jose "Martin" Abeleira. AKA Marto) #19

Got it :wink: