OpenVPN net2net problem

Hi all!
I have 2 server nethserver
i configured wan, lan(bridge) its all ok.
i configured openvpn from doc
i create master and slave server.
slave server connected to master its ok.
slave server to master server and lan 1 - ping ok!
LAN2 to master server and lan 1 - no ping and no access!
master server to slave server and lan 2 - no ping and no access!
LAN1 to slave server and LAN 2 - no ping and no access!
how i additionally must configured that all work?
sorry my English please…
my network scheme

I think @davide_marini could help you on this :smile:

Hi, in order to make things work you need routed (tun) interface and you need to specify remote subnet on each slave client.

1 Like

Our testingteam created a howto for such a situation. Have a look here and see if it is usefull for you: Setup muliple site office with point-to-point ipsec vpn and separate DC

Also keep in mind that both subnets must be different: (this is not an issue with your situation because you already created different subnets)

I prefer OpenVPN irroute :

not solved in Nethesrver 7.2.1511 (rc2)
same problem.
How to solution with OpenVPN?

IPSec tunnel work fine!

I solved the problem
I did not carefully read the documentation
thanks to all