OpenProject into CentOS 7 (NethServer 7.x): a diary, an experience

  • no expert of any kind of Project management tools/software
  • no linux admin expert at all
  • prone to mistake dude at keyboard

You have been warned

So… how that’s gonna be? Straight and simple, some steps and notes i had writing down an experience about installing OpenProject on a NethServer test installation. No support provided, no expert at the keyboard. Don’t ask for help, keep looking for answers, solutions than… provide them here if you like.

The experience is done into a virtual environment. Take note of that.

Getting started

  • Install Nethserver

  • Do a nice yum update, just in case, after the reboot. Do you have received a fresh kernel? Be smart, reboot again :wink:

  • Add your favourite tools. In my case yum install mc links nano open-vm-tools

  • From hereInstall openproject ; this sequence is my edited version:

    wget -O /etc/yum.repos.d/openproject.repo \ https://dl.packager.io/srv/opf/openproject/stable/11/installer/el/7.repo
    yum update
    yum install openproject

  • Still not done installing… because the “real source of knowledge” is elsewhere… So i added a yum install catdoc unrtf poppler-utils tesseract to the recipee; AFAIK poppler-utils should not be necessary, because already provided but… should not harm, at least on CentOS7/NethServer. Full-text extraction should not be supported on this Distro, but i tried with these packages to pack this onboard anyway. Consider if might be useful add yum install tesseract-langpack-[ISO 3 letter code] for your language, AFAIK eng is part of the package

  • Time for a openproject configure, read carefully the walkthrought of the configuration.

7 Likes

First “not nice” experience.
image

You can have the “stock” experience with this translation instead of UTF8
ISO-8859-1:1998 (Latin-1, West Europe)
This don’t means that others translation will correcly work. Not please to see not-UTF8 menu

Also: no @ allowed into email password (holy …)

I set my OpenProject email settings post install via SMTP. I cannot say if the @ works per se but my passwords work with different symbols, alpha/numeric inputs.

I can say that the password i would like to use starts with @ and this shout out an error (but not into data entry at configuration)… Consider to not use it for OpenProject, currently.