Onlyoffice Webtop integration testing

Inspired by @KdB here, I updated the Onlyoffice module to integrate itself to Webtop automatically.

  • Increased JWT length to 32 chars for more security and to work with Webtop
  • Webtop is configured and restarted to use Onlyoffice immediately
  • Fixed error when the host variable wasn’t set - now SystemName.DomainName is used when no host is defined
  • It does not work with the Webtop admin

Please test it and report errors:

Install as described in the wiki and replace the last line with

yum -y install https://mrmarkuz.goip.de/mirror/devtest/nethserver-onlyoffice-0.0.1-8.ns7.noarch.rpm
4 Likes

Had to restart tomcat8 service but I think it is unrelated to the module:

OnlyOffice working fine within webtop and nextcloud and without having to move a finger.

2 Likes

That’s excellent Markus. Worked perfectly on a clean install.

I tried a few scenarios including installing WebTop after OnlyOffice and everything was in place as it should have been.

Thank you so much for your work.

Klaus

3 Likes

Big thanks for testing guys!

Module released.

1 Like

Updated webtop5 and nextcloud from testing repo and was unable to open documents with onlyoffice even when the document server URL was reachable. After many failed attempts it worked restarting supervisord service.
When you find time, could you check event_services in createlinks?

1 Like

Thanks for pointing that out.
I corrected the service typo and integrated rabbitmq-server and supervisord as Nethserver services so we see a warning in UI if a service is not started.
Additionally the onlyoffice postgres user now has a secure password instead of “onlyoffice”.

If you already installed the beta version, you need to reinstall:

yum clean all; yum reinstall nethserver-onlyoffice

1 Like