ONLYOFFICE error (It is not possible to save the document)

Hi Community,

I tried to install ONLYOFFICE with:

yum -y install
yum -y install
yum -y install
yum -y install nethserver-onlyoffice --enablerepo=mrmarkuz

The installation went through, I am able to create a new textfile (Neues Textdokument) but get an error when I try to create a new document (Neues Dokument) or spreadsheet (Neue Tabelle):


This is the error-msg:

It says, It is not possible to save the document… Maybe one of you know the error and could help?

Hi and welcome to NethServer Community,

do you use a valid certificate (like letsencrypt)? Can you reach the onlyoffice server at https://yourdomain.tld:8082 ?

There are some troubleshooting steps in the wiki.

Is it possible to save the settings in the onlyoffice app without error?
Does it help to recreate the database?

Please also check logs in /var/log/onlyoffice/documentserver/* and in Nextcloud.

Maybe related:

No, maybe this is the problem. I was thinking it is possible without a valid cert because the creation of a simple textfile (.md) worked.

Output of /var/log/onlyoffice/documentserver/converter/out.log:

[2022-04-20T13:27:51.833] [ERROR] nodeJS - error downloadFile:url=https://srv1.test.lan/nextcloud/index.php/apps/onlyoffice/download?doc=eyJ0eXAiO ... M9M4AQ_w;attempt=3;code:DEPTH_ZERO_SELF_SIGNED_CERT;connect:null;(id=2845852478)
Error: self signed certificate
    at TLSSocket.onConnectSecure (_tls_wrap.js:1514:34)
    at TLSSocket.emit (events.js:400:28)
    at TLSSocket._finishInit (_tls_wrap.js:936:8)
    at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:708:12)

Text files are opened in Nextcloud itself, there’s no Onlyoffice involved.
It should be possible but it needs to be configured, see wiki chapter about self-signed certs
I recommend to use letsencrypt as it’s simple to setup and the more secure way.

1 Like

OK, thank you

1 Like