Error after Onlyoffice upgrade

NethServer Version: 7.9
Module: nextcloud 22.2.3

I have several servers with NC 22.2.3 and OnlyOffice document server 6.4.xxxx working correctly.
Yesterday, on one, the app OnlyOfiice got disabled.
I went to check as NC admin and saw that the 7.0.2 connector was disabled and marked as “application not verified” and that the 7.3.0 update was ready.
I checked the other servers that still work and I saw that the connector installed is version 7.2.0 …
I proceeded with the update of the connector on the server not working, the OnlyOffice was re-enabled but with the already known error “violates local access rules”, I ran the command in WiKi and when I went to click “SAVE”, NC it told me that 7.3.0 was not compatible with document server
Next step, update the document server to version 7.0.0 … Everything looked ok, but …

Will you help me? Thank you

Schermata da 2022-01-21 12-28-09

(an error occurred while opening the file. Click on “OK” to return to the document list).

This error always appears, existing or newly created documents.

Thanks for reporting. I can confirm the issue with onlyoffice-documentserver 7.0.0-132. I need to check, I’m afraid a DB upgrade isn’t working correctly. This is the error I got after updating:

Incorrect DB_TYPE value! Possible value of DB_TYPE is 'postgres' or 'mysql'.
warning: %post(onlyoffice-documentserver-7.0.0-132.x86_64) scriptlet failed, exit status 1

It seems to be compatible to document server 6.4.2-6:


As a workaround you could downgrade:

yum downgrade

Reapply config and restart services:

signal-event nethserver-onlyoffice-update

1 Like

Great job.
Done, now all OK

Sorry, bat in your wiki:

Is this an error?

Grazie 1000

1 Like

No, it’s meant to replace x.x.x.x with the actual version.
Some time ago the rpm name and location changed, I just wanted to point that out.


Yes, I corrected it.



1 Like

Recreating the database solves the issue regarding the update to documentserver 7.0, see wiki.

1 Like

Not here…

Screenshot 2022-01-22 100707



Did you try to completely remove documentserver, remove the database and install documentserver 7 again?

Did you find relevant log entries?

Please also share your installed onlyoffice RPMs.

rpm -qa *onlyoffice*

Here it’s working on 2 servers. I’m going to try to reproduce your issue later.

Hi mrmarkuz, after a long period with covid i am a little bit confused.

Here is th output of rpm -qa *onlyoffice*:

rpm -qa onlyoffice

I have updated to version 7.0.0 as you described in your instructions. After that I have renewed the database.


And then I have this error in the log of my NC that keeps repeating:

Error onlyoffice Exception: Im Dokumentenservice ist ein Fehler aufgetreten: Conversion error
/usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php - line 94:


/usr/share/nextcloud/apps/onlyoffice/lib/preview.php - line 269:

OCA\Onlyoffice\DocumentService->GetConvertedUri(“https://clo … 0”, “xlsx”, “jpeg”, “2511239571”)

/usr/share/nextcloud/lib/private/Preview/ProviderV1Adapter.php - line 53:

OCA\Onlyoffice\Preview->getThumbnail(“Arbeitszeit … 9”, 4096, 4096, false, OC\Files\View {})

/usr/share/nextcloud/lib/private/Preview/GeneratorHelper.php - line 62:

OC\Preview\ProviderV1Adapter->getThumbnail(OC\Files\Node\File {}, 4096, 4096)

/usr/share/nextcloud/lib/private/Preview/Generator.php - line 245:

OC\Preview\GeneratorHelper->getThumbnail(OC\Preview\ProviderV1Adapter {}, OC\Files\Node\File {}, 4096, 4096)

/usr/share/nextcloud/lib/private/Preview/Generator.php - line 140:

OC\Preview\Generator->getMaxPreview(OC\Files\Sim … {}, OC\Files\Node\File {}, “application … t”, “”)

/usr/share/nextcloud/lib/private/Preview/Generator.php - line 109:

OC\Preview\Generator->generatePreviews(OC\Files\Node\File {}, [ { width: 4 … }], “application … t”)

/usr/share/nextcloud/lib/private/PreviewManager.php - line 189:

OC\Preview\Generator->getPreview(OC\Files\Node\File {}, 44, 44, true, “fill”, “application … t”)

/usr/share/nextcloud/apps/files_versions/lib/Controller/PreviewController.php - line 99:

OC\PreviewManager->getPreview(OC\Files\Node\File {}, 44, 44, true, “fill”, “application … t”)

/usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 217:

OCA\Files_Versions\Controller\PreviewController->getPreview(OC\Files\Node\File {}, 44, 44, “1641914319”)
/usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 126:

OC\AppFramework\Http\Dispatcher->executeController(OCA\Files_Ve … {}, “getPreview”)

/usr/share/nextcloud/lib/private/AppFramework/App.php - line 156:

OC\AppFramework\Http\Dispatcher->dispatch(OCA\Files_Ve … {}, “getPreview”)

/usr/share/nextcloud/lib/private/Route/Router.php - line 302:

OC\AppFramework\App::main(“OCA\Files_ … r”, “getPreview”, OC\AppFramew … {}, { _route: "f … "})

/usr/share/nextcloud/lib/base.php - line 1006:


/usr/share/nextcloud/index.php - line 36:


Edit 2: Downgraded to V 6.4.2 and everything works well.

I could reproduce the issue. I thought it’s just about removing the DB but maybe removing and installing onlyoffice did the trick.

It should work with following steps but I recommend to stay with version 6.4 until 7.0 is more integrated (for instance metrics doesn’t start because it uses the same port as netdata).
I think I need to provide a module update.

yum -y remove onlyoffice-documentserver

su - postgres -c "psql -c 'drop database onlyoffice;'"

yum -y install

yum -y install nethserver-onlyoffice

Good Morning mrmarkuz and thank you for helping me.

In general, the installation of version 7 works as you described above. But then the scan throws me this error message. Possibly the system seems to expect another file. I followed your recommendation and reinstalled version 6.4.2 completely. But the error message remains. See pictures…

I could reproduce, I guess the integrity check fails because the onlyoffice app changed a file in Nextcloud. It’s not a big problem and can be ignored.

The recommended way is just replacing the file Nextcloud complains about, see wiki or Nextcloud docs.

Get the right, should be 22.2.3:


Backup the file:

cp /usr/share/nextcloud/core/js/mimetypelist.js ~

Maybe you need to install unzip:

yum install unzip

Unzip the file to the Nextcloud path:

unzip -j nextcloud/core/js/mimetypelist.js -d /usr/share/nextcloud/core/js

Clean up:


I found that reinstalling Nextcloud removes the warning too as it restores all files to the original ones but I had issues with onlyoffice afterwards so I DO NOT recommend it in this case…

1 Like

Now it works like before. Thank you.

1 Like

3 posts were split to a new topic: Full reinstall of Nextcloud

Hi mrmarkuz,

after a update to the latest version of NC the red message is back again. But everything works without problems.

I can’t reproduce the warning on my servers.

Could you please share the “list of invalid files” to check if it’s an issue?

Here i have a pic of the “list of invalid files”.

1 Like

It can be ignored, it’s the same as here.

Ok, i will do so.

Thank you…

1 Like