Ns8-wordpress something new to test

add-module ghcr.io/nethserver/wordpress:1.0.0-dev.1


I am lost for words. It simply works! Maybe the best thing since sliced bread :wink:

Merci bien!


Can you explain what it does ?

Is it a WordPress extension or the installation of WordPress ?


If I may reply, it is the full install of the latest Wordpress version for NS8 as an all-in-one module. And as @stephdl indicates it is a first test release.

1 Like

@stephdl haven’t tested it yet or looked into it yet,

Does it offer an option to explore the files of wp, especially for plugins and themes uploading.

Does it offer a means to access the dB using phpmyadmin?

I believe the 2 scenarios are important for serious wp hosting.

No, maybe a plugin could be enabled ?

Not offered the database is not opened to the outside

What are the requirements ?

What to do after installation ? Configuration ?

I tried with OpenLDAP, Rouncubemail, and WebTop already installed:

Assertion failed
  File "/var/lib/nethserver/cluster/actions/add-module/50update", line 223, in <module>
    agent.assert_exp(create_module_result['exit_code'] == 0) # Ensure create-module is successful

    223 agent.assert_exp(create_module_result['exit_code'] == 0) # Ensure create-module is successful

Went back to a VM restoration with only OpenLDAP installed:

{'module_id': 'wordpress1', 'image_name': 'wordpress', 'image_url': 'ghcr.io/nethserver/wordpress:1.0.0-dev.1'}

Nothing shows up in Software center / Installed.

Nothing shows up with: http://toto.org

With locate:

[root@debian-12 ~]# locate wp-config
[root@debian-12 ~]# cd /home/wordpress1/.local/share/containers/storage/vfs/dir/dfbe01fd0b8357f6ebca0e0ae85a55f8c5af1d58612a13e1f36e98b1545f982f/usr/src/wordpress
[root@debian-12 wordpress]#

Will try later, I have to go out for now.


Check the application menu in upper right corner

1 Like

9 posts were split to a new topic: Increase the size of the Debian VM



Hi @Andy_Wismer

The swap resolved the main problem of resize…:

I deleted the swap and the extended partitons.

I created a new swap:

[root@ns8 ~]# fdisk -l
Disque /dev/sda : 82 GiB, 88046829568 octets, 171966464 secteurs
Modèle de disque : QEMU HARDDISK
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'Ă©tiquette de disque : dos
Identifiant de disque : 0x95722270

Périphérique Amorçage     Début       Fin  Secteurs Taille Id Type
/dev/sda1    *             2048 165771263 165769216    79G 83 Linux
/dev/sda2             165771264 171966463   6195200     3G 82 partition d'Ă©change Linux / So
[root@ns8 ~]#

I prepared the swap structure

[root@ns8 ~]# mkswap /dev/sda2
mkswap: /dev/sda2 : avertissement : n'effacez pas les secteurs de démarrage
        (dos table de partitions détectée). Utilisez -f pour forcer.
Configure l'espace d'Ă©change (swap) en version 1, taille = 3 GiB (3171938304 octets)
pas d'Ă©tiquette, UUID=f5cf9f8a-34d9-4b56-a1e7-143b518f98f1
[root@ns8 ~]#

To find the UUID of the swap:

[root@ns8 etc]# ls -ls /dev/disk/by-uuid/
total 0
0 lrwxrwxrwx 1 root root 9 26 fév 20:20 2023-09-03-00-51-30-00 -> ../../sr0
0 lrwxrwxrwx 1 root root 10 26 fév 20:23 78149948-08bf-4992-9184-e117b91a03eb -> ../../sda2
0 lrwxrwxrwx 1 root root 10 26 fév 20:23 f0e78aa9-5bb4-482d-9887-fecc774a7db4 -> ../../sda1
[root@ns8 etc]#

UUDI of the swap: 78149948-08bf-4992-9184-e117b91a03eb -> ../../sda2

Edit /etc/fstab and verify:

[root@ns8 ~]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# systemd generates mount units based on this file, see systemd.mount(5).
# Please run 'systemctl daemon-reload' after making changes here.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=f0e78aa9-5bb4-482d-9887-fecc774a7db4 /               ext4    errors=remount-ro 0       1

# swap was on /dev/sda5 during installation
#####UUID=2ba26de1-d2c1-4332-9d35-95b648685371 none            swap    sw              0       0
UUID=78149948-08bf-4992-9184-e117b91a03eb none            swap    sw              0       0

/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
[root@ns8 ~]#

And finally:

[root@ns8 ~]# swapon -a
[root@ns8 ~]#

Using swapon, shows that the swap is activated.

[root@ns8 ~]# swapon
/dev/sda2 partition   3G   0B   -2
[root@ns8 ~]#

Reboot the system.

[root@ns8 ~]# reboot
[root@ns8 ~]#

I can now access the cluster-admin page.


As @LayLow wrote: “Maybe the best thing since sliced bread.”

[root@ns8 ~]# add-module ghcr.io/nethserver/wordpress:1.0.0-dev.1
<7>podman-pull-missing ghcr.io/nethserver/wordpress:1.0.0-dev.1
Trying to pull ghcr.io/nethserver/wordpress:1.0.0-dev.1...
Getting image source signatures
Copying blob sha256:5c3e29f395d485a75141a04d616d8e85a33ead124b9c7d925bccef6be2eb2e9c
Copying config sha256:b773f38a01496644f04abc7769feb864095271c98429f963476213a9a6c412e1
Writing manifest to image destination
{'module_id': 'wordpress1', 'image_name': 'wordpress', 'image_url': 'ghcr.io/nethserver/wordpress:1.0.0-dev.1'}
[root@ns8 ~]#

The miracle!


image Total triumph, let us raise the banner of victory.

What’s left:

The only little problem left is the ...no codecs found...


But when I was googling to solve the resize problem, I found a lot of references to it. So it should be possible to solve that also.

@Andy, Thank you so much for the little notice about the swap. That was the boost that enable me to solve the whole resize problem, and (for @stephdl) the last but not least, I have to “kill” nothing and mainly no reinstallation…




As a small side note for your docs:

The correct use of swapon to show the usage of swap is

swapon --show

If say using mirrored disks, one could also create multiple swap partitions, these would show up a continous swap volume:

mkswap /dev/sda4
mkswap /dev/sdb4

The swap needs to be created:

swapon /dev/sda4
swapon /dev/sdb4

then use

swapon --show
/dev/sda4 partition 8.2G   0B   -2
/dev/sdb4 partition 8.2G   0B   -3

to show the whole swap…

My 2 cents

What can I say?
Great job! Congratulations!

  1. Installing the module: no problems.
  2. Wordpress1 → Settings → Request LE Certificate: the certificate was obtained immediately.
  3. Installation of the new wordpress theme: no problems.
  4. Installing new plug-ins: no problems.
  5. Customize the new theme: no problems.
  6. The site works with any mode of the permalink structure I choose.

If we could have access to the DB…
I have some errors when configuring the WP Super Cache - Test Cache plugin (The pages do not match! Timestamps differ or were not found!), but I think they can be solved in the future.

I installed the theme and the plug-ins I use on my website in NS7 and everything works like there, unlike the virtual host in the NS8 webserver.
Big difference between Apache and NGINX.
I remain of the opinion that something is not working well in the webserver module, maybe the phpfpm@ service (it only works with Permalink structure → Plain, in Customize mode there are website display errors, if in Settings → General WordPress Address (URL) and Site Address (URL) is used https:// instead of http://, you cannot enter in wp-admin because the error “The page isn’t redirecting properly” appears - depending on the browser, …). All this, regardless of whether I’m migrating the site or installing it from scratch.

Best regards,

1 Like

You can access the database by cli

Do you need phpmyadmin ?

I release the stable and I accept PR if you want to play with dev


I beleive PHPMyadmin is very necessary for any Wordpress based hosting.

WHile bundling it within the worpdress module would be the easier option,

it will not make sense if there are multiple wordpress installations.

Is it not possible for the current PMA available in mysql module to be useable, if not,
WOuld it not be possible to implement a Dedicated PMA for WP APPlication DB,s Access.

I am of the view this will imporve working with Wordpress on NS8

1 Like

For me, it would be much easier! :blush:

1 Like

Hi @michelandre

It seems as though that “codec” is not specific to WordPress, it refers to an Intel Sound Chip, but generally to the server hardware it’s running on. (The Odroid? That would explain Intel…)
Normally, no one would want to play sound from a Webserver directly on a server, usually because no one is sitting next to a server… :slight_smile:

Probably a simple install of the generic open source media codecs on the Debian would suffice, YMMV…

Don’t forget, Proxmox is based on Debian, just as your VM…
May help with this (hardware?) issue?

My 2 cents

post_max_size =256M

not really convenient but wordpress does not give me env vars

so to modify it go to /home/wordpress1/.config/state/config/uploads.ini and adjust your settings, your modifications are included inside the backup


direct cd or via ssh wordpress1@localhost first?

Could you Update this Soemwher ein the docs SMH because this content in here might be buried soon, But generally if those details are the defined default, they are pretty fair for WP

This is looking really good. Too questions:

  1. After adjusting settings in the upload.ini file, how does one restart/reset the module? I can see the changes, but they don’t show up in my wordpress install.

  2. Trying to setup MailPoet in Wordpress, I’m getting a PDO_MYSQL PHP extension error. Is there a way I can add the PDO PHP extension? Or can it be added to the module?

I’ve been struggling with the php_fpm issues on the webserver module for a while. This already feels like a much more stable solution. Thanks for the effort!