Ns8 samba file permissions problems

Hello, i have a problem after migration from ns7 to ns8 with samba ad.

Some shares have file and folders are read only for users. Not all, i can not understand why.
If i make a copy of a file, the copy became writable.
If i try to delete old file and folders, i have not permissions enaugh to delete or edit. I can only rename.
On cluster-admin i tried to assign the group again but nothing changes.

How can i fix this problem?

Thank you.

1 Like

Hi @sarz4fun

A small tip from the front…

The shares are essentially for Windows clients.
It’s also Windows clients having issues to access the shares.
This is the third migrated clien I have seen this issue - and also have to provide a solution…

If Linux methods don’t work - it’s Windows clients haveing issues…
Why not have the Windows Superuser (AKA Domain Admin) fix it?

It actually works!

I had to empty the folder (I could grab a zipped veersion from PBS Backup, very current…
Set the permissions I wanted, with the correct Owner / Group.
Then, as Domain Admin, copy the files from the Windows VM / Notebook I was using for this task back to the NS8 share.

I had to repeat this procedure for all shares (Including User Homes, here fixed as User), one by one.
In all 3 cases, only 2-3 shares were really used, so it wasn’t too much work.

Since then, permissions have held.

Hope this helps.

My 2 cents

Thank you for the suggestion, I hope for a more elegant solution.
It will be a long operation.

Hi @sarz4fun

I would have preferred a built in GUI solution, but had to migrate…

There are still a LOT of options missing in File Server:

  • Trashcan per Share, Yes / No
  • Trashan emptying per Share, Time Options
  • Allow opening executable (specifically for Windows)
  • Permissions setting per Share, Recursive (Yes No), “Sledgehammer” Option
  • and much more…

A few tips:

AFAIK, it would also work setting the permissions from a Windows Workstation, logged in as Domain Administrator. Samba respects Windows AD settings…
Either using CLI (Windows/Samba Options, not chown/chmod (those too, including facls).
or also using GroupPolicy…

In Cluster Admin, when setting permissions on shares, set the main group and choose the center option below.


My 2 cents

I hope these features will be available soon.
Ns7 was great as a Windows file server.
I have migrated my hemelab to ns8 and It took 8 hours for the first file sync. Now i have to copy files again, manually…
I think is better to wait for a more stable situation to migrate my production environments.
I can not stop file sharing service for hours or days to wait file copy twice.

This has not worked for me. Maybe because i have only 1 group (homelab users)? (Exluding domain admins)

I need to +1 this as being an important issue. I’ve migrated a couple of my smaller clients, but I am going to have to wait on the larger ones as this will be a huge issue for them. I won’t have the time to move all that data essentially 3 times.

Hello @Andy_Wismer,
I have made several attempts from Windows with the administrator account to set the share permissions, but nothing works. I think the only way, as you say, is to empty the shares and fill it with a backup manually.

1 Like


One trick which seems to work, but is not really optimal…

Add all users to Domain Admins group
Set all share permissions again (To the intended group, not Domain Admins!)

Users must login again.

Besides PDF or other files which need Excutable permissions, this seems to work, maybe as a workaround until a really better solution is available.

My 2 cents


This workaround works well.
Should i keep users on domain users group to keep shares writable?

1 Like

For as long as needed, or a better solution is available.
Works for me too, need to use this for 2 clients.

Not really happy, but it works…

My 2 cemts

1 Like