NS 7 rc2 cannot browse neither home dir nor shares

hello folks,
I’ve just fired up from scratch NS 7 rc2.
I’ve added a test user, and successfully joined the AD style domain, with a Win 7 client, with its credentials.

It has its home in /var/lib/nethserver/home/myuser
I cannot browse, from Windows client, its home directory \\myserver\myuser
Bizarrely, browsing \\myserver gives back sysvol and netlogon folders.

Any suggestion?
Thanks in advance.

the display of sysvol and netlogon happens with \\ip_address.
If I specify _\\myserver.mydomain.com_ nothing hppens.
DNS server on client are NS7 IPs.

it sounds like a dns problem if you can get the server over it’s ip.
Please try \ipadress\myuser
Did you get your folder?

hi @m.traeumner
to be clear:
AD IP address
NS IP address

I may say DNS is correct, because either ping or nslookup of myserver.mydomain.com return
moreover, ping mydomain.com returns

I can access netlogon and sysvol via, which is correct because those are AD related.
I cannot access \\\myuser

I created myuser without ssh access. Then I created myuser_ssh, with ssh access granted.
\\\myuser = no acces
\\\myuser@mydomain.com = browsing home directory
\\\myuser_ssh = browsing home directory

I went back on webGUI, however the ssh checkbox for mysuer is grayed, no way to activate.
With myuser I have no access on filesystem, neither via ssh nor su - myuser.

I’ve tested it, I’ve nearly same problems. My client is win 7 but in another domain. So I’ve tried to connect with other user settings, no chance and with a ssh-user named I can access with winscp but only with domainname.

\\\myuser = no acces
\\\myuser_ssh@mydomain.com = browsing home directory
\\\myuser_ssh = no access (access denied)

well, to accomplish this result
\\\myuser_ssh = browsing home directory
I’ve followed Home directory of users in AD article, that is in Community BUG section.
It tells, before logging on with a user, to perform a su - <username> on NS.
This is what I did with myuser_ssh, so I could browse myuser_ssh home directory.

and you did it with myuser too?
I’ve done it, but nothing changed.
Perhaps somebody else can help.

1 Like

I tried to reproduce the problem without success. This is my procedure:

  • created “third.user” on NS7 with Samba4 DC (gdev2.neth.eu), set password
  • from a domain workstation (win10) logged in as “third.user”, domain “neth.eu
  • connected to \\gdev2\third.user@neth.eu

In gdev2 /var/log/messages:

Nov 17 16:20:53 gdev2 smbd[4320]: pam_unix(samba:session): session opened for user third.user@neth.eu by (uid=0)

The home dir was created during PAM login for third.user, under /var/lib/nethserver/home/third.user.

The su - ... is not required! :no_entry:

Dear all,
I close this topic, due to NS 7 Final released, and none of the described situations happened.
Thanks to all.