W10 no mapping home directory

NethServer Version: 7.3.1611

After installing Nethserver and succesfull connecting W10Pro client to AD, all shares can be mapped, only home directory is not accesible. Windows is claiming that authorisation is incorrect.
So far I’ve found no clues in the forum or internet.

Any suggestion?

When login as the user is its home folder shown from Windows 10 network places?

1 Like

Yes, together with the shares all folders are visible under windows network places, in which the home folder is presented as long user name folder

And the user gets an error when accessing this folder?

If that’s the case, what’s the output of:

getfacl /var/lib/nethserver/home/username/

(replacing username as appropriate)

Yes the user get an error message saying that the authentication went wrong, contact system administrator.

Output of the command:

[root@yz2nsrv ~]# getfacl /var/lib/nethserver/home/guus/
getfacl: Removing leading ‘/’ from absolute path names
file: var/lib/nethserver/home/guus/
owner: 802401105
group: 802400513
flags: s–

on unix level I see the user and domain ID’s are correct

As of just now under network I see an aditional directory,
in addition to the shares I saw up till now
all other shares

This mapping is also not reachable.

yes, nethserver gets a bit confusing here :slight_smile:
are you mapping the homeshare from a script, or from a groupolicy?
currently, i have a mapping.cmd running from inside the user’s startup folder, this seems to map all the shares correctly :slight_smile: under network places you see a username@domainname folder, which is equal to the username folder, i can map both folders, and they show the same content :slight_smile:

Hello Jan,

I tried mapping from windows explorer. just to test

Is there some example for a script and where do I have to store it, where is the users startup folder?
I guess I put the script within a shell in the right diretory on the server since I don’t see any tools within de web interface. Or should it be put on the windows 10 client?


So I made a file in the windows start directory and all mapping works just fine except the mapping to the home directory, the connection is still refused.

Contents of the file:

net use all /delete
net use H: /home
net use I: \\yz2nsrv\fotos /persistent:yes
net use J: \\yz2nsrv\yzermuziek /persistent:yes
net use K: \\yz2nsrv\downloaddata /persistent:yes
net use L: \\yz2nsrv\backup /persistent:yes
net use M: \\yz2nsrv\oc-data /persistent:yes

when I use for home directory the following command I see a mapping H: but this one is also not available

net use H: \\yz2nsrv\guus

My computer has joined the domain so why does the home mapping not function? Where doe I have to look to solve this?


1 Like

Did you tried with guus@your.domain?

Please refer to this thread:

Hello Davide,

your test gave me the clou.
Created a new account, log messages looked good and mapping to home directory possible.

My guess is that since I created the home directories with rsync data transfer from old server that after changing the GID/UID this wasn’t sufficient and probably causing the connection error.

The UID as well as the GID are wrong, because they are the unix parameters of the old server, not the samba parameters.

How easy the solution can be.

Thanks for all support helping me to the solution.



I’m happy you found it :trophy: