No Updates after Test-Period


(Michael Träumner) #1

I’ve tested the subscription at my test environment. @giacomo After you informed me that test is over I can’t update my system any more. Following error I get on yum update:

[root@GroupwareBackup log]# yum update
Loaded plugins: changelog, fastestmirror, nethserver_events
https://m1.nethserver.com/stable/7.4.1708/base/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

https://m1.nethserver.com/stable/7.4.1708/centos-sclo-rh/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.


 One of the configured repositories failed (Stable mirror: SCLo rh 7),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=sb-centos-sclo-rh ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable sb-centos-sclo-rh
        or
            subscription-manager repos --disable=sb-centos-sclo-rh

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=sb-centos-sclo-rh.skip_if_unavailable=true

failure: repodata/repomd.xml from sb-centos-sclo-rh: [Errno 256] No more mirrors to try.
https://m1.nethserver.com/stable/7.4.1708/centos-sclo-rh/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden

I found that it also could be a DNS Problem, so I tried to ping google and the name is resolved, but the data packages are not send.

[root@GroupwareBackup log]# ping www.google.de
PING www.google.de (172.217.18.163) 56(84) bytes of data.

^C
--- www.google.de ping statistics ---
140 packets transmitted, 0 received, 100% packet loss, time 138999ms

(Jorge Jiménez) #2

It sounds to me more like a routing problem?

can you achieve any other connection outside your lan from that machine.

try this:

wget https://www.google.es/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png

and see if you are able to download the file


(Giacomo Sanchietti) #3

You need to disable the subscription and restore default repos:

config setprop Secret '' SystemId ''
eorepo base centos-sclo-rh centos-sclo-sclo epel extras nethforge nethserver-base nethserver-updates updates

Update problems
(Michael Träumner) #4

@jjimenez, @giacomo
Thanks for your answers, after doing the steps of Giacomo everything wents fine again.